Figer l'utilisation d'une formule à condition...

[Résolu/Fermé]
Signaler
Messages postés
115
Date d'inscription
vendredi 24 mai 2013
Statut
Membre
Dernière intervention
23 novembre 2015
-
Messages postés
115
Date d'inscription
vendredi 24 mai 2013
Statut
Membre
Dernière intervention
23 novembre 2015
-
Bonjour,

Je voudrai
si les 100% ne sont pas atteint, on applique la formule
si les 100% sont atteint, on fige la valeur


et j'aimerai que lorsque je change le pourcentage pour le mettre en dessous 100% que le compteur reprenne enfaite. c'est vraiment figer le compteur lorsque c'est 100% en figeant la formule mais lorsque le % et modifié que la formule reprenne.


3 réponses

Messages postés
115
Date d'inscription
vendredi 24 mai 2013
Statut
Membre
Dernière intervention
23 novembre 2015
16
https://www.cjoint.com/?CFsilCO3SRG

voila le fichier test
Messages postés
26186
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 053
Bonjour
question
y a t il un lien entre la date en colonne I dernière imputation et la colonne K avancement technique
ou posée autrement:
y a t'il un lien pour situer la date à laquelle le 100% est atteint
crdlmnt

Messages postés
115
Date d'inscription
vendredi 24 mai 2013
Statut
Membre
Dernière intervention
23 novembre 2015
16
Alors bonjour et merci de ta reponse.

Enfait je t'explique la colonne avancement technique (%) du tableau inférieur ca sera de la saisie sur une autre feuille excel.
La colonne Avancement technique (%) du tableau supérieur vient récupérer le pourcentage dans le tableau du dessous "SI" le service "&" le code tâche sont les mêmes.
Ensuite la colonne de délai aujourd'hui permet de calculer le nombre de jours restant entre aujourd"hui et la date de fin client. Cette cellule se sert d'une cellule qui contient "=AUJOURDHUI()" et d'une autre qui contient la date de fin client (ciblé dans le second tableau de la même manière que l'avancement).

Le 100% n'a donc pas de lien avec la date ce sera une inforrmation saisie par les personne sur le térrain qui jugerons de l'avancement technique.

C'est pourquoi afin d'éviter que lorsque la tâche a été saisie et jugée éffectuée à 100% je souhaiterai que la colonne avancement délai jours restant soit figée.

En gros lorsque la cellule de la colonne avancement technique a etait saisie à 100% la cellule contenant le délai restant en jours doit céssé d'utiliser la formule qu'elle contient (=jours360(AUJOURDHUI();DATE DE FIN CLIENT). Mais je veux aussi que si le pourcentage est modifié et remis a 90% (par exemple) la formule redevienne active.

A l'inverse si le pourcentage est < à 100% la formule doit bien enttendu rester active.
Messages postés
115
Date d'inscription
vendredi 24 mai 2013
Statut
Membre
Dernière intervention
23 novembre 2015
16
j'espere que c'est clair comme c'est assez difficile à expliquer =). merci en tous cas.
Messages postés
26186
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 053
RE
Bien compris, mais...
.. pour ce qui concerne mes compétences, le 100% n'étant lié qu'à l'entrée de la valeur dans la cellule, ,il faudra passer par VBA pour figer les formules que l'on pourrait mettre pour calculer le délai restant.
Mais je ne suis pas un spécialiste de VBA d'où mon problème pour répondre!
Il faut en effet figer le résultat et donc supprimer la formule , et la réintégrer si le 100% est modifié à la baisse
la seule chose que je peux proposer et une formule qui calcule le délai restant, mais qui au lieu de figer la valeur du délai dans les cas de 100% afficherait par exemple: terminé dans la colonne Délai restant., et qui afficherai le délai dans tous les autres cas
cette formule en L3:

=SI(K3=1;"terminé";C3-AUJOURDHUI())

à toi de voir. Mais on va surement trouvé un spécialiste de VBA ici, il y en a des très bons, pour gérer ça

crdlmnt
Messages postés
26186
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 053
Curieux, je viens d'envoyer un message est il est vide?

je recommence donc
je disais donc:
S'il n'y a pas de date d'affectation des 100% je ne sais pas garder le délai restant à partir de l'affectation.
VBA pourrait traiter ça, à savoir: figer le résultat délai restant à l'entrée des 100% et remettre le calcul si le 100% est modifié à la baisse.
Mais VBA n'est pas dans mes compétences à ce niveau là.
Tout ce que je peux proposer est une formule qui affiche par exemple: "terminé" dans la colonne délai si le taux est de 100% et sinon calcule le délai restant
soit en L3:
=SI(K3=1;"terminé";C3-AUJOURDHUI())

Sinon je vous laisse dans les mains des compétences VBA de CCM et il y en a des bonnes, je vous rassure.

crdlmnt
Messages postés
115
Date d'inscription
vendredi 24 mai 2013
Statut
Membre
Dernière intervention
23 novembre 2015
16
merci beaucoup oui c'est ce que je pensais aussi je n'est aucune compétence et les dernière solution en VBA proposées n'ont pas fonctionnées... mais c'est pas grave merci bien =)
Messages postés
115
Date d'inscription
vendredi 24 mai 2013
Statut
Membre
Dernière intervention
23 novembre 2015
16
UP =/