Rapprochement données excel 2003 [Résolu/Fermé]

Signaler
-
Messages postés
23504
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
26 septembre 2020
-
bonjour,

j'ai une feuille excel 2003 sous la forme suivante:

en colonne 1 4000 références
en colonne 2 5000 références dont les 4000 de la colonne 1

les 1000 références de différence sont mélangées dans la colonne 2.

je souhaiterai "nettoyer" cette colonne 2 en enlevant automatiquement ces 1000 références.

y a t'il une solution?

merci de votre gentille et précieuse aide.

eric


2 réponses

Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 496
Bonjour
en colonne C, la formule à tirer sur la hauteur:
=SI(NB.SI(A:A;B1);B1;"")
les références de B qui n'existe pas en A seront éliminées de la colonne C
une fois cette colonne remplie/ copier là et faites un collage spécial valeur, plus un tri pour supprimer les vides

mais je suis un peu surpris de la question, car vous allez retrouver ainsi dans C la liste de référence de A ???

si toutefois, à l'inverse, vous voulez retrouver uniquement en C les références de B qui n'existent pas en A:
=SI(NB.SI(A:A;B1)=0;B1;"")

crdlmnt

merci beaucoup pour votre compétence car cela fait plusieurs questions que je posent et vos réponses sont toujours aussi claires malgré ma méconnaissance de excel.
j'en aurai d'ailleurs une toute simple que je vais mettre sur le forum.

Bien cordailement.

eric
Messages postés
23504
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
26 septembre 2020
6 367
Je sens le fromage ???
eric
Messages postés
23504
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
26 septembre 2020
6 367
Bonjour à tous,

je souhaiterai "nettoyer" cette colonne 2 en enlevant automatiquement ces 1000 références.

Ben c'est la colonne 1 donc.
Quelque chose m'échappe là...

eric
bonjour,

oui cela correspond donc à la colonne 1 mais ce qui m'intéresse c'est les 1000 nouvelles références que je dois ensuite importer dans ma base article.

mon souci a été résolu par vaucluse.

bien cordialement.

eric du 19
Messages postés
23504
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
26 septembre 2020
6 367
ok, donc tu désires les garder, et enlever les 4000 autres...