Filtrer et trier données excel

Résolu/Fermé
-
 eric19 -
bonjour,

je dois créer une feuille excel à partir de 2 autres feuilles que je dois trier en fonction de certains critéres; la feuille 1 est la base de l'ensemble des produits supprimés, la feuille 2 est la base totale et la feuille 3 est la feuille à créer qui enléve de la feuiile 2 l'ensemble des produits supprimés de la feuille 1: je m'explique plus précisemment:

feuille 1: base produits supprimés
a1: 110000 b1: adhesif c1:prix

feuille 2: ancienne base article
a1: 110000 b1: adhesif c1:prix
a2: 110025 b2: colle c2:prix
a3: 110050 b3: papier c3:prix

feuille 3: base à créer
a1: 110025 b1: colle c1:prix
a2: 110050 b2: papier c2:prix

merci pour votre aide dans la crétion de la formule excel.

bien cordialement

eric

1 réponse

Messages postés
26409
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
6 191
Bonjour
avec une colonne intermédiaire, mais il faudrait décaler les données d'une ligne pour laisser la cellule D1 libre
(insérer une ligne en tête de feuille sur les deux feuilles de données

feuil2 et à placer sur la hauteur voulue, à partir de D2 donc:
en Dé (ou ailleurs sur la ligne 2)
=SI(NB.SI(Feuil1!B:B;B2);"";MAX($D$1:D1)+1
attention à la position des signes $

sur la feuille 3, en commençant en ligne 2 aussi:
en colonne A
=SI(LIGNE()-1<=MAX(Feuil2!D:D);INDEX(Feuil2!A:C;EQUIV(LIGNE()-1;Feuil2!D:D;0);1));"")
en colonne B
=SI(LIGNE()-1<=MAX(Feuil2!D:D);INDEX(Feuil2!A:C;EQUIV(LIGNE()-1;Feuil2!D:D;0);2));"")
en colonne C
=SI(LIGNE()-1<=MAX(Feuil2!D:D);INDEX(Feuil2!A:C;EQUIV(LIGNE()-1;Feuil2!D:D;0);3));"")

vous pouvez en final faire un copier coller spécial valeur sur la feuil3 pour éliminer les formules

Autrement plus simplement, vous pouvez envisager une mise en forme conditionnelle en feuille 2 en nommant en feuil1 le champ de la colonne B par exemple Liste
et en appliquant en feuille 2 colonne B cette formule pour la ,mise en forme conditionnelle:
=NB.SI(Liste;B1)
formatez en rouge. Il ne restera qu'à supprimer les rouges de feuil2 pour mettre la,iste à jour
Errare humanum est, perseverare diabolicum
merci beaucoup pour votre aide et félicitations pour vos compétences; cela fonctionne trés bien.

eric