Mise en évidence des doublons [Résolu/Fermé]

Signaler
-
 Goodwin -
Bonjour,

Je cherche à mettre en évidence les noms qui se répètent dans une colonne, j'ai trouvé cette formule =NB.SI($A1:$J1;A1)>1, pour la mise en forme conditionnelle.
Mais le problème c'est qu'elle ne me colore pas la dernière répétition du doublons mais les répétition précédente. Hors moi j'aimerais qu'ils soient tous colorés.

Encore merci d'avance.

3 réponses

Messages postés
20393
Date d'inscription
mercredi 18 avril 2007
Statut
Contributeur
Dernière intervention
25 janvier 2021
1 566
Je suppose évidement que c'est pas du Excel 2010...
dans excel 2010, dans la mise en forme conditionnelle, y'a une option qui fait ça directement.

Stop failing the turing test !
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 735
Bonjour
Vous êtes sur?
Parce que la formule que vous utilisez formate bien toutes les références en doublon
(sauf bien sur si vous les effacez et qu'il n'en reste qu'une)
voyez ici
https://www.cjoint.com/?CDjrJVUixf1

dna.factory
l'option existe aussi en 2007, mais sauf erreur, le hic si on veut traiter un tableau ligne par ligne est qu'il faut la placer spécifiquement à chaque ligne

crdlmnt
Je suis évidement sur du 2003.

Bizarrement votre formule fonctionne correctement en ligne mais le problème se pose en colonne : =NB.SI($A1:$A100;A1)>1