Faire une somme sans tenir compte des cellules #valeur! [Résolu/Fermé]

Signaler
-
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
-
Bonjour,

je suis désolé la pagination était bien et une fois que j'ai validé mon message c'est "dépaginé"
Je pensais pouvoir garder le copier/coller d'excel.

j'es^ère donc que ma pagination survivra au "valider " cette fois ci.

quantité Prix Prix pour la quantité
1 22,62 22,62
12 4,8 57,6
1 4,8 4,8
#VALEUR!
#VALEUR!
TOTAL #NOM?

dans la cellule ou apparait le sigle #NOM?
j'ai mis la formule =SOMME.SI(plageJ11:J11:J26;"";J11:J26)

2 réponses

Messages postés
493
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
4 mai 2015
119
Bonjour,

Met ton fichier excel sur https://www.cjoint.com/ et colle le lien obtenue dans ta prochaine réponse.

Bien entendu ne met aucune information confidentiel dans le fichier que tu vas nous passer ^^
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bonjour

le plus simple serait probablement d'éliminer les résultats #VALEUR dans le champ à sommer

Soit si formule renvoie VALEUR, écrire:

=SI(ESTERREUR(formule);"";Formule)

qui laissera des cellules vides pas gênantes pour la somme si vous utilisez:
=SOMME(J11:J26) tout simplement

car plage J11 etc... ne sont pas admis par Excerl, d'ou le renvoi #NOM

crdlmnt
Messages postés
4
Date d'inscription
mardi 19 février 2013
Statut
Membre
Dernière intervention
23 mars 2013

Effectivement je me disais qu'il faudrait trouver une solution pour éviter que le terme #VAleur! apparaisse mais je n'avais aucune solution .
mais alors là je ne connaissais pas du tout cette formule .
J'ai remplacé formule par (mon produit C12*d12) et ça marche impeccable.

Merci chaleureusement à Vaucluse cela fait 2 fois que vous me trouvez la solution je vous en remercie
venant seulement de pouvoir me connecter je n'avais pas eu le temps de mettre mon fichier sur le lien proposé par Dracknard mais comme je dois encore apporter quelques subtilité à mon fichier .
Je risque d'avoir encore d'avoir besoin de ce forum.


Si je comprends bien en mettant ESTERREUR on indique que quelque soit le message d'erreur qui apparait dans la formule (VALEUR , NOM , #N/A, etc ... au lieu de faire apparaitre le message il ne met rien. L'argument SI permettant de garder la formule active si les cellules mères permettent à la formule d'avoir un résultat.
Je ne trouve plus l'endroit ou je peux indiquer que le pb à été résolu.
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Exact, demartia, le code ESTERREUR détecte tous les défauts de résultats et affiche la valeur prévue dans la condition correspondante
Par exemple, si vous placez "non trouvé" entre les deux guillemets, la formule va afficher non trouvé dans la cellule.
J'ai mis le post en résolu.
Bonne route
Crdlmnt