Somme avec 2 critères - XLS 2003 [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mardi 19 mars 2013
Statut
Membre
Dernière intervention
19 mars 2013
-
Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
-
Bonjour,
vous trouverez ci-joint le fichier exemple.
Mon problème ressemble à une fonction somme.si ou sommeprod, mais dans les deux cas je n'ai pas réussis à trouver la formulation.

Mon problème :
additionner les valeurs contenu en colonne C en tenant compte des critères en colonne A et B

plages de critères :
A:A : Date compris entre la date affichée sur la ligne de la formule et la date -3mois (possibilité de tenir compte uniquement des périodes mois() )
B:B : Ref article doit etre egal a la ref affiché sur la ligne de la formule

Résultat :
C:C : Somme des quantités répondant aux 2 critères

Mes tentatives :
Pour somme.si, 1 seul conditon possible
=SOMME.SI(B:B;B30;C:C) Ne tient pas compte du critère date
Pour sommeprod, les critères ne peuvent pas eter contenu dans une cellule mais écrient entre guillements.
=SOMMEprod((A:A>A39-93)*(B:B=B39)*(C:C)) affiche erreur nombre car les critères sont compris dans des cellules. (A39-93 correspond à la date -3mois a peut près sachant qu'il n'y a qu'une date par mois)
Pour ce qui est duTCD, ca serait peut etre possible en inserrant 1 champ calculé, mais je ne maitrise pas cette fonction.


Merci pour votre aide, dans l'attente de réponses.

Hugo



2 réponses

Messages postés
17408
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 juillet 2021
4 668
Salut,

Pour joindre ton fichier, avec ce lien

https://www.cjoint.com/

je regarde ta formule sur tes dires
Messages postés
2
Date d'inscription
mardi 19 mars 2013
Statut
Membre
Dernière intervention
19 mars 2013

Merci,
finalement je n'ai pas tres bien saisie pourquoi mais la formule sommeprod fonctionne si on remplace les plages de colonnes entières par des plages délimitée.

Hugo
Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
5 992
Bonsoir
oui, vous l'avez dit, !! c'est tout simplement parce que le code SOMMEPROD n'accepte pas les colonnes entières, il semble, comme la fonction est matricielle, qu'il n'ai pas été conçu avec cette option.
Sauf peut être dans certains cas dans des version récentes d'Excel.
crdlmnt