Excel, calcul d'ecart entre diff. colonnes de diff. feuilles

[Résolu/Fermé]
Signaler
Messages postés
9
Date d'inscription
mercredi 13 mars 2013
Statut
Membre
Dernière intervention
30 décembre 2013
-
Messages postés
5693
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
15 octobre 2021
-
Bonjour,

Y a-t-il quelqu'un pour rechercher un numéro?
C'est pour trouver un numéro manquant ... merci.

Voila j'ai 1 classeur avec differentes feuilles.

Feuille 5 = initiale
Feuille 1 = Parc A
Feuille 2 = Parc B
Feuille 3 = Parc C
Feuille 4 = Parc D

J'aimerais pouvoir comparer les colonnes Q,AA, et AK de la feuille 5 avec les colonnes O,Y, et AI des feuilles ( Feuille1 + Feuille 2 + Feuille 3 + Feuille 4).

J'aimerais que l'écart me soit copié dans une Feuille 6 = écarts

Pour être un peu plus claire :

Ma feuille 5 est ma feuille de référence que j'ai éclaté ensuite en 4 feuilles.
J'aimerais confirmer que je retrouve tous mes numéros de la feuille 5 dans les 4 autres feuilles .
- Comparer colonne Q de la feuille 5 avec les numéros de la colonne O des 4 autres feuilles, si le numéro est présent dans la feuille 5 (colonne Q) et n'apparait dans aucune des 4 autres feuilles (colonne O) alors il faudrait le copier dans la feuille 6.

- Comparer colonne AA de la feuille 5 avec les numéros de la colonne Y des 4 autres feuilles, si le numéro est présent dans la feuille 5 (colonne AA) et n'apparait dans aucune des 4 autres feuilles (colonne Y) alors il faudrait le copier dans la feuille 6.

- Comparer colonne AK de la feuille 5 avec les numéros de la colonne AI des 4 autres feuilles, si le numéro est présent dans la feuille 5 (colonne AK) et n'apparait dans aucune des 4 autres feuilles (colonne AI) alors il faudrait le copier dans la feuille 6.

Merci


7 réponses

Messages postés
502
Date d'inscription
mercredi 6 mars 2013
Statut
Membre
Dernière intervention
16 janvier 2016
198
bonjour, par exemple dans le premier cas
tu vas dans la feuille 6, et tu te sers de la formule:
=SI(Feuil5!Q6<>(Feuil1!O6&Feuil2!O6&Feuil3!O6&Feuil4!O6);F6;"")&SI(Feuil5!Q6=0;"";"")
Messages postés
9
Date d'inscription
mercredi 13 mars 2013
Statut
Membre
Dernière intervention
30 décembre 2013

Merci pour cette formule, je viens de l'essayer et elle ne fonctionne pas.
Si j'ai bien compris ta formule mache par ligne (dans l'xemple ligne 6)

Dans mon classeur les numéro ne sont pas resté sur la meme ligne que initialement (feuille 5)

Exemple: je peux avoir L1 sur Feuille 1, ce même numéro se retouve L44 sur Feuille 3.

C'est pourquoi je veux comparer les colonnes et pas les lignes.

Aurais tu une autre piste?
Messages postés
5693
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
15 octobre 2021
662
Bonjour

la formule pour le premier cas

=SI(ET(ESTERREUR(RECHERCHEV(Initial!$Q10;'Parc A'!$O:$O;1;FAUX));ESTERREUR(RECHERCHEV(Initial!$Q10;'Parc B'!$O:$O;1;FAUX));ESTERREUR(RECHERCHEV(Initial!$Q10;'Parc C'!$O:$O;1;FAUX));ESTERREUR(RECHERCHEV(Initial!$Q10;'Parc D'!$O:$O;1;FAUX)));Initial!$Q10;"")

2 cas

=SI(ET(ESTERREUR(RECHERCHEV(Initial!$AA10;'Parc A'!$Y:$Y;1;FAUX));ESTERREUR(RECHERCHEV(Initial!$AA10;'Parc B'!$Y:$Y;1;FAUX));ESTERREUR(RECHERCHEV(Initial!$AA10;'Parc C'!$Y:$Y;1;FAUX));ESTERREUR(RECHERCHEV(Initial!$AA10;'Parc D'!$Y:$Y;1;FAUX)));Initial!$AA10;"")

3 cas

=SI(ET(ESTERREUR(RECHERCHEV(Initial!$AK10;'Parc A'!$AI:$AI;1;FAUX));ESTERREUR(RECHERCHEV(Initial!$AK10;'Parc B'!$AI:$AI;1;FAUX));ESTERREUR(RECHERCHEV(Initial!$AK10;'Parc C'!$AI:$AI;1;FAUX));ESTERREUR(RECHERCHEV(Initial!$AK10;'Parc D'!$AI:$AI;1;FAUX)));Initial!$AK10;"")


j'espère que cela conviendra
Messages postés
9
Date d'inscription
mercredi 13 mars 2013
Statut
Membre
Dernière intervention
30 décembre 2013

Merci cela ne marche pas non plus j'ai #Nom.
Cette formule semble aussi s'appliquer par ligne n'est ce pas?

Ce que j'aimerais pouvoir effectuer c'est une formule qui puisse dire que le nombre "X" est présent dans la colonne Q de la feuille 5 et n'est plus présent dans les colonnes O des feuille 1, 2, 3 et 4 sans tenir compte de la ligne d'origine ni finale.

Le nombre X étant tous les numéros de la colonne Q de la feuille 5
Messages postés
5693
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
15 octobre 2021
662
Non la recherche se fait sur la colonne et si vous avez NOM cela est peut être dû au nom de la feuille
Pour votre nouvelle demande de présence dans une feuille pas dans une autre cela change la formule
je vais regarder les posibilitées
Messages postés
9
Date d'inscription
mercredi 13 mars 2013
Statut
Membre
Dernière intervention
30 décembre 2013

Si vous avez des questions ou autre n'hésitez pas.

Peut etre serait il plus simple si je vous envois mon fichier vous comprendrez peut etre mieux?

En tout cas merci pour votre temps passé pour chercher une solution
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 229
Bonjour

pour joindre une pièce
mettre le classeur sans données confidentielles en pièce jointe sur
https://www.cjoint.com/
puis copier l'adresse du lien et la coller dans le message de réponse

Combien as tu de lignes environ ?

On peut le faire par formule avec 4 NB.SI(colonne parc A;feuille initiale)=0; l'inconvénient étant que tu auras une liste discontinue si le nombre existe dans les parcs par exemple on aura un nombre, puis la ligne d'en dessous "", puis ligne d'en dessous un nombre

Pour avoir une liste avec uniquement les manquants, il serait préférable d'itiliser une macro

tu dis...



Michel
Messages postés
5693
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
15 octobre 2021
662
Bonjour

La formule modifié

=SI(ESTERREUR(RECHERCHEV(Initial!Q10;'Parc A'!O:O;1;FAUX));Initial!Q10&" absent Parc A - ";Initial!Q10&" présent Parc A - ")&SI(ESTERREUR(RECHERCHEV(Initial!Q10;'Parc B'!O:O;1;FAUX));Initial!Q10&" absent Parc B -";Initial!Q10&" présent Parc B -")&SI(ESTERREUR(RECHERCHEV(Initial!Q10;'Parc C'!O:O;1;FAUX));Initial!Q10&" absent Parc C -";Initial!Q10&" présent Parc C -")&SI(ESTERREUR(RECHERCHEV(Initial!Q10;'Parc D'!O:O;1;FAUX));Initial!Q10&" absent Parc D -";Initial!Q10&" présent Parc D -")

dites moi si cela vous convient
Messages postés
9
Date d'inscription
mercredi 13 mars 2013
Statut
Membre
Dernière intervention
30 décembre 2013

Philou10120,

J'ai continué a chercher avec ta formule, mon erreur venait d'un nom de fichier (espace manquant) et aussi et c'est la ou j'ai eu du mal c'est qu'il faut coller la formule dans a colonne O.

Merci beaucoup pour ton aide :)
Messages postés
5693
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
15 octobre 2021
662
Pour copier la formule copier la dans une cellule en mettant une strophe comme du texte cela évite que les adresses se modifient une fois placé au bonne endroit enlever la strophe et la formule affichera le résultat dés que vous ferez entrer
Rien ne vous oblige à la mettre colonne O sur nom modéle elle est en D7