[Batch] impossible de lancer un lien internet

[Résolu/Fermé]
Signaler
Messages postés
5
Date d'inscription
jeudi 28 février 2013
Statut
Membre
Dernière intervention
28 février 2013
-
Messages postés
5
Date d'inscription
jeudi 28 février 2013
Statut
Membre
Dernière intervention
28 février 2013
-
Salut tous le monde , voila j'ai un problème j'essaie de m'entraîner à programmer en batch (je suis un débutant) mais voila j'ai un petit soucie quand j'essaye de lancer un lien internet via la commande start cela ne fonctionne pas la fenêtre se ferme automatiquement meme avec la commande pause voila je laisse mon code batch :
Merci de votre aide.

@echo off
echo Sur quelle site voulez vous allez tapez (ex:google)
set /p site =site:
if %site%==google goto google
if %site%==youtube goto youtube
:google
start www.google.fr
@echo lancement de google
pause>nul
:youtube
start www.google.Fr
@echo lancement de youtube
pause>nul

1 réponse

Messages postés
18246
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
21 juillet 2021
5 331
hello
pas d'espace autour de = dans set /p
mettre des guillemets dans les tests
set /p site=site:
if "%site%"=="google" goto google
if "%site%"=="youtube" goto youtube
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
5
Date d'inscription
jeudi 28 février 2013
Statut
Membre
Dernière intervention
28 février 2013

merci beaucoup dubcek ! j'ai chercher pendant des heures *-*