2 conditions dans la même cellule [Résolu/Fermé]

Signaler
-
 patjul -
Bonjour,

j'aimerais connaitre cette formule:si E3est < 13 et si D3> = 19 alors 1 sinon 0

4 réponses

Messages postés
16431
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
9 avril 2021
3 162
Bonjour,

=(E3<13)*(D3>=19)

Michel
Messages postés
3
Date d'inscription
dimanche 24 février 2013
Statut
Membre
Dernière intervention
24 février 2013

merci,mais cela ne fonctione pas (office 2013)Voici mon sujet: si je commence à travailler avant 13h en D3 j'ai droit à 1 repas sinon rien,et si je commence à travailler en E3 à ou après 19h j'ai droit à 1repas.Réponse 1 ou 0 dans F3.
merci de m'aider.
Messages postés
25954
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
5 867
Bonjour patjul et bonjour Michel

ben ... faut poser les question correctement, si vous voulez des heures, demandez des heures!!

remplacez 13 parc 13/24 et 19 par 19/24
quand on parle d'heure l'unité de temps de Excel est le jour soit 1=24h

crdlmnt
Messages postés
3
Date d'inscription
dimanche 24 février 2013
Statut
Membre
Dernière intervention
24 février 2013

cela est vrai mais je reste en standart car 1h30 pour moi est 1,5
cdlt
Messages postés
25954
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
5 867
Oui mais pour Excel c'est 0,0625. Si vous restez en standard, il faut entre vos heures d'entrée et de sortie en num standard et dans ce cas, la proposition de Michel fonctionne?
et bien sur 1:30 PM est 13,5, donc
Alors où est la question?
......sauf si vous l'avez mal posé au départ auquel cas il faudrait remplacer le ET de la proposition de Michel par OU, car pour le moment conformément à votre demande, pour avoir 1,, il faut commencer avant 13h ET finir après 19h.
crdlmnt
Messages postés
3
Date d'inscription
dimanche 24 février 2013
Statut
Membre
Dernière intervention
24 février 2013

si je commence en D3 à 12 et fini en E3 à18,en F3 devrait apparaitre 1, mais j'ai 0
Pour E3 à 19 ou après apparait bien 1
je découvre seulement excel.
Merci de votre temps Cdtl
Messages postés
25954
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
5 867
Alors essayez de l'écrire autrement, soit:

=SI(OU(E3<13;D3>19);1;0)

Et bon appétit.

crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
16431
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
9 avril 2021
3 162
Bonjour Vaucluse,
J'admire ta patience et ta diplomatie :o)....

petite remarque:
le test de SI(...;) renvoie toujours vrai- faux (booléen) et comme on teste sur des nombres on a toujours 1 ou 0 et on test sur des textes il faut multiplier par 1
=(E13<13)+(D3>19)
ou bien
=OU(E3<13;D3>19)
Messages postés
16431
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
9 avril 2021
3 162
=(E13<13)+(D3>19)
à remplacer par
=((E13<13)+(D3>19) >0)
merci à tous,Michel cela fonctionne.
cdlt