Gestion des dates d'arrêt de maladie

Fermé
Praljm
Messages postés
30
Date d'inscription
jeudi 24 janvier 2013
Statut
Membre
Dernière intervention
30 mars 2018
- Modifié par Praljm le 21/02/2013 à 14:30
via55
Messages postés
13613
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
25 mai 2022
- 15 mars 2013 à 10:34
Bonjour,

J'ai un fichier d'arrêts de travail, classé par noms, et chaque nom peut avoir 1 ou plusieurs arrêts.
Je dois identifier les noms pour lesquels le nombre de jours cumulés est supérieur ou égal à 30 (soit en seul arret soit en arrets consécutifs, avec les dates qui se suivent).

Je cherche la formule qui permet ce calcul à partir du nom.
Merci d'avance.
Cordialement


A voir également:

3 réponses

via55
Messages postés
13613
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
25 mai 2022
2 404
21 févr. 2013 à 21:36
Bonsoir,

Sans exemple de fichier par facile à dire

Une piste cependant :
Tu dois avoir une colonne date début et une colonne date fin pour chaque arrêt et une colonne qui par différence des dates calcule le nombre de jours d'arrêt
Pour gérer les arrêts consécutifs comme un seul arrêt il faudrait rajouter une colonne avec une formule qui additionne les jours si dates consécutives

ex date debut en C date fin en D nombres jours en E =>en F3 formule =SI(C3=D2; E3+F2;E3)

Ensuite si la liste des noms est colonne B et si en G1 on rentre un nom la formule en H1 =NB.SI.ENS(B2:B15;G1;F2:F15;">=30") retourne le nombre des arrets >= 30 pour le nom voulu trouvés dans la plage F2:F15

ou en H1 =SOMME.SI.ENS(F2:F15;B2:B15;G1;F2:F15;">=30") retourne la somme des jours d'arrêts (>=30)

ou si version excel antérieure à 2007 :
=SOMMEPROD((B2:B15=G1)*(F2:F15>=30)) retourne le nombre d'arrêts

Cordialement
0
Praljm
Messages postés
30
Date d'inscription
jeudi 24 janvier 2013
Statut
Membre
Dernière intervention
30 mars 2018

15 mars 2013 à 09:25
Bonjour, et merci !
Je réponds tardivement au message.
Je vais tenter cette méthode.
Merci beaucoup .
Cordialement.
0
Praljm
Messages postés
30
Date d'inscription
jeudi 24 janvier 2013
Statut
Membre
Dernière intervention
30 mars 2018

15 mars 2013 à 09:50
Je ne comprends pas la formule. Il faut que c3 = d2 + 1. la date de fin de com ne peut pas être la même que celle de la prolongation.

ex date debut en C date fin en D nombres jours en E =>en F3 formule =SI(C3=D2; E3+F2;E3

=> comment fait on pour mettre une PJ sur ce forum ?

merci
Cdt
0
via55
Messages postés
13613
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
25 mai 2022
2 404
15 mars 2013 à 10:34
Bonjour

Oui le +1 avait du être omis en recopiant la formule

Pour joindre ton fichier allégé et anonymé tu pases par le site cjoint.com et tu indiques ensuite le lien fourni dans un prochain message

Cdmt
0