HDD reconnu dans le bios mais pas dans l'install Windows 7 [Fermé]

Signaler
-
Messages postés
8
Date d'inscription
samedi 3 septembre 2016
Statut
Membre
Dernière intervention
4 septembre 2016
-
Salut a tous.

Je viens de monter ma nouvelle config, prise sur le modèle power gaming hardware.fr (en kit, sans OS)
Niveau hardware, tout semble OK.

Par contre, au moment ou j'essaye d'installer mon windows 7, il ne me propose pas mon disque barracuda 2 TO sata.
A la place, je ne vois qu'un disque de 128 GO, sur lequel je ne peut d'ailleurs pas lancer l'installation.

Pourtant, dans le bios je vois bien un ST2000DM001 sur le sata 1.

Alors, j'ai bien essayé de passé le controleur sata en mode IDE dans le bios ( ca ne change rien.)
Et j'ai cherché un driver sur le DVD de la carte mere ( MSI Z77A-G45 ) : aucun trouvé.

Je suis preneur de toute suggestion : j'ai passé l'aprem a monter le joujou ( j'ai pris mon temps.) et je commence a être frustré ...

Merci d'avance pour toute aide.

A voir également:

5 réponses

Alors, c'est bien un bios UEFI.

Par contre, je chercher encore si le disque est GPT ou MBR.

Ca changerais quoi, et je pourrai essayer quoi dans ce cas ?
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Déjà, essaie de voir si tu as une option legacy boot, ou legacy only ou both... active-la. Regarde aussi si un boot secure n'est pas activé (en principe non, mais sait-on jamais).
Remets en sata, tant que tu y es.

http://doc.ubuntu-fr.org/lib/exe/fetch.php?hash=40b281&media=http%3A%2F%2Fpix.toile-libre.org%2Fupload%2Foriginal%2F1347270332.jpg

Après tu démarres avec ton W7 et tu essaies... si W7 est toujours réticent, tu redémarres sur ton W7, tu choisis "réparer", tu lances la console en mode de commande et tu tapes
diskpart
list disk (il doit le voir)
select disk n (selon le numéro de ton disque)
clean (on supprime tout)
convert mbr
exit

En principe, là ton W7 doit pouvoir s'installer.

Bjr,

Une piste, sans garantie:

La carte mère est équipée d'un bios ou d'un bios-uefi ? Le disque dur ne serait-il pas au format gpt au lieu de mbr ?
Messages postés
8
Date d'inscription
samedi 3 septembre 2016
Statut
Membre
Dernière intervention
4 septembre 2016
1
j'ai excatement le meme probleme que toi, avec le meme disque dur ST2000DM001, toujours pas de solution, je commence aussi a desesperer
Tout d'abord merci pour cette réponse. Mais pour l'instant je suis toujours en galere.

voila ce que je trouve en fouillant les menu de mon bios :

La seule mention de legacy dans mon BIOS concerne PCI ROM priority.

Je ne trouve aucune mention de secure boot.

Comme mode SATA, j'ai le choix entre IDE, AHCI, et RAID.
Celui par defaut est AHCI.

Une option qui m'interpelle est "Configuration de super IO"
Dedans, je peut configurer mon port serie 0. Pour l'instant il est en mode auto. Les autres mode proposés sont du modele IO=3F8h; IRQ=3,4,5,6,7 ..

Sinon, en essayant les manips que tu suggere dans la cnosole, je vois bien un disque. Mais toujours en tant que 128 GO.
La tentative de le convertir en MBR echoue a cause d'une erreur I/O.

Je commence a sentir poindre du découragement ...

il y a bien un emplacement jumper sur mon DD, mais aucune indicatino de ce a quoi il correspondent. Par defaut, il n'y a aucun jumper dessus. J'ai essayé les 3 positions possibles ... aucune ne change rien.
Honnêtement, je ne peux t'en dire plus... tant que tu es en UEFI, je pense ton W7 ne reconnaîtra pas ton HDD. Et je n'ai pas de bios UEFI sous les yeux pour t'aider...

Moi, j'activerais cette option:

legacy BIOS PCI ROM priority Elle semble forcer l'option bios.

Et je referais un essai...


Je viens de trouver le manuel de ta CM... je jette un oeil.
Une discussion proche pour faire le contraire, passer en UEFI (Asus)

Dans le manuel, il est précisé que tu as une option "UEFI / Legacy Boot" (dans le menu "Boot" du BIOS).

Y'a trois options possible :

- Enable Boot UEFI and Legacy (active les deux options de démarage)
- Disable UEFI (desactive UEFI)
- Disable Legacy (n'active que UEFI)

L'option par défaut, c'est sur : "Enable Boot UEFI and Legacy"

Donc, logiquement c'est bon.., mais si ça ne marche pas, passe sur "Disable Legacy".

Et juste en dessous tu as l'option : "PCI ROM Priority"

Avec en options :

- Legacy ROM (exécute une ROM héritée)
- EFI Compatible ROM (exécute une ROM compatible UEFI)

Par défaut, c'est sur : "Legacy ROM"

Donc ça il faut le passer sur "EFI Compatible ROM"
Ma carte mere est une MSI Z77A-G45.

Il me semble que je n'ai malheureusement pas d'option pour desactiver l'UEFI et passer en legacy.
J'ai bien une option "PCI ROM priority", mais la passer sur EFI Compatible ROM n'a rien changé.
C'est tout de même surprenant... j'avoue que ça m'étonne. A quoi servirait cette option si tu ne peux pas sortir du mode UEFI.... ça doit forcément s'appeler autrement chez toi, mais l'option ne peut que s'y trouver.


Pour preuve:

https://www.downloadsource.fr/1770269/msi-z77a-g45-thunderbolt-bios/ (la version 10.2 du bios supporte le legacy mode... il faut peut-être (déjà) flasher le bios).

Tout est dit ici...

http://fr.msi.com/product/mb/Z77A-G45-Thunderbolt.html#/?div=BIOS
http://fr.msi.com/service/biosupdate/