Somme d'une plage variable [Fermé]

Signaler
Messages postés
3
Date d'inscription
mercredi 13 février 2013
Statut
Membre
Dernière intervention
13 février 2013
-
Messages postés
12235
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
6 janvier 2021
-
Bonjour,


Je souhaiterai faire une somme sous Excel.
Une somme qui a pour début une valeur fixe (cellule figée "L"3 par exemple) jusqu'à) une cellule de la même ligne (3 dans l'exemple) trouvée via une rechercheh.

Voici ce que j'ai fait :
=SOMME(L3;RECHERCHEH($AI$2;$L$2:$AF$34;2;0))
Mais cela me calcule uniquement les deux valeurs et non l'ensemble des valeurs comprises entre ces deux nombres ...

Quelqu'un a t-il une idée ?

4 réponses

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 290
Bonjour ,

problème de syntaxe :
=SOMME(L3;L10) fera la somme de L3 et L10
=SOMME(lL:L10) fera la somme des cellules de L3 à L10

Il faut donc remplacer le point-virgule par deux points dans votre formule.

Cordialement.
Messages postés
3
Date d'inscription
mercredi 13 février 2013
Statut
Membre
Dernière intervention
13 février 2013

j'ai déjà essayé cela mais ca ne fonctionne pas avec la rechercheh ...
Messages postés
12235
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
6 janvier 2021
2 558
Bonjour,

RECHERCHEH ne vous aidera pas.
Essayez un mix entre SOMME, DECALER et INDEX, un peu comme ceci :

=SOMME(L3:DECALER(L3;;;EQUIV(AI2;L2:AF2);2))

- EQUIV(AI2;L2:AF2) vous donnera le nombre de colonnes à "décaler à partir de L3
- 2 est le nombre de ligne à décaler (hauteur)
Cordialement,
Franck P
Messages postés
3
Date d'inscription
mercredi 13 février 2013
Statut
Membre
Dernière intervention
13 février 2013

Merci.

Mais je souhaite faire le calcul ligne par ligne.
Avec cette formule mes calculs de somme de lignes sont liés.

Je ne souhaite donc pas décaler en hauteur (le 2 dans votre exemple ci-dessus) ...
Messages postés
12235
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
6 janvier 2021
2 558
ben remplace 2 par 0.........................................................