Copier cellule seulement si date identique

Résolu/Fermé
Signaler
-
Messages postés
15
Date d'inscription
lundi 15 septembre 2003
Statut
Membre
Dernière intervention
3 août 2016
-
Bonjour,

Voici une chose que je n'arrive pas à faire sous forme de formule
Pour ne pas compliquer les choses avec des multiples lignes je vous le pose comme suit (et j'adapterai si besoin)

si une date dans la colonne C (feuil1) est identique à celle de la cellule A1 (feuil2) alors inscrire en D1 (feuil1) la valeur de la cellule A2 (feuil2)

merci d'avance



5 réponses

Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 130
Bonsoir
cette formule risque fort de renvoyer #NA si la date n'est pas dans la colonne C PHILOU!
Mais peut être que le demandeur pourra s'en arranger

Je préférerais en D1 feuil1

=SI(NB.SI(C:C;Feuil2!A1);Feuil2!A2;"")

crdlmnt




1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 130
Bonjour
et pourtant.. elle tourne!

Ceci dit pour votre dernière question, toujours avec le même code:

En D1
=SI(NB.SI(Feuil2!$A$1:$M$1;C1);RECHERCHEH(C1;Feuille2!$A$1:$M$2;2;0);"")

Vous renvois la valeur de la ligne 2 en colonne avec la date C en ligne 1 si celle ci existe en A1:M1
sinon ne renvoie rien.
Comme ça en fait:. Est ce bien ce que vous cherchez
https://www.cjoint.com/c/CBjjrLFeinL

Si jamais vous ne vous en sortez pas avec NB.SI, reprenéz le code PHILOU SI(ESTERREUR(ECT....

crdlmnt
Merci Vaucluse

c'est pratiquement ça
ta formule =SI(NB.SI(etc...) est inscrite dans toutes les cellules de la colonne D feuil1

Je souhaiterai le résultat que (dans ton exemple) en A1

donc si une date marquée en colonne C feuil1 est identique A1:M1 feuil2
alors afficher en A1 feuil1 (et seulement dans cette cellule) la valeur correspondante à cette date

J'utilise (novice) les formules si, rechercheH...
je ne connais pas esterreur
je vais potasser ça

encore merci
Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 130
Re
alors ça peut être?
mais il faut une colonne intermédiaire.. du moins tant que je n'ai rien trouvé d'autre!
https://www.cjoint.com/?CBjkOAmAtJw
crdlmnt
Messages postés
15
Date d'inscription
lundi 15 septembre 2003
Statut
Membre
Dernière intervention
3 août 2016
1
j'ai retrouvé mon login et mdp, c'est toujours moi

ca devient beaucoup trop complexe pour moi,
dans un tableau qui contient dejà une quantité énorme de formule en tous genres

je vais garder la vieille méthode du "regarder/recopier"

je donne quand meme un exemple
https://www.cjoint.com/?CBjlSqwEnwS

fais moi savoir si tu ne peux plus rien pour moi et je marque "RESOLU"

encore merci
Messages postés
5724
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
1 décembre 2021
675
Bonjour

Si j'ai bien compris vos données

=SI(RECHERCHEV(Feuil2!$A$1;$C$1:$C$10;1;FAUX);Feuil2!A2;"")
Messages postés
5724
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
1 décembre 2021
675
Bonsoir

La même formule avec contrôle des erreurs au cas ou la rechercheV n'aboutie pas

=SI(ESTERREUR(RECHERCHEV(Feuil2!$A$1;$C$1:$C$10;1;FAUX));"";SI(RECHERCHEV(Feuil2!$A$1;$C$1:$C$10;1;FAUX);Feuil2!A2;""))
Bonjour et merci pour cette répose ultra rapide
cela m'a permis de potasser ça pendant une bonne partie de la soirée
et de faire quelques modifs pour que ça fonctionne

la première formule fonctionne mais affiche N/A lorsqu'elle est vide
la seconde fonctionne
Je n'arrive pas à faire fonctionner la formule de Vaucluse

Si je peux encore abuser de votre temps
et toujours en faisant simple
voici mon cas réel que je n'arrive pas à faire

feuil1 colonne C s'affiche des dates
feuil1 D1 là ou doit s'afficher le resultat
feuil 2 de A1 à M1 s'affiche le dernier jour de chaque mois (31/01/13, 28/02/13 ...)
feuil 2 de A2 à M2 s'affiche une valeur correspondante à la date

si une date dans la colonne C (feuil1) est identique à celle d'une cellule A1:M1 (feuil2) alors inscrire en D1 (feuil1) la valeur de la cellule A2:M2(feuil2) correspondant à cette date

j'ai essayé avec la première formule séparé par ; mais ça ne marche pas

merci d'avance
Messages postés
5724
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
1 décembre 2021
675
Bonjour

La formule de Vaucluse fonctionne

=SI(NB.SI(Feuil2!$A$1:$M$1;$C$1);RECHERCHEH($C$1;Feuil2!$A$1:$M$2;2;FAUX);"")

Elle affiche bien le résultat de la rechercheH elle est plus simple que la mienne
Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 130
Bonjour PHILOU

effectivement,..... ou peut être; mais ça ne veut pas dire que la votre était mauvaise..!

Il y a bien des cas ou utiliser le code ESTERREUR est bien utile, et ce n'est pas une mauvaise chose que le demandeur puisse en être informé.

( je m'en sert par exemple dans le dernier fichier proposé suite à la dernière demande de goliath)

Bon WE
Messages postés
5724
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
1 décembre 2021
675
je suis preneur de toutes les bonnes idées, j'apprends par la pratique donc avec vous par vos suggestion.
Messages postés
5724
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
1 décembre 2021
675
Bonjour

Dans l'exemple fourni il n'y a rien en C1
mettre cette formule
=FIN.MOIS(C6;0)

Et en C15 celle-ci
=SI(NB.SI(Feuil2!$A$1:$M$1;$C$1);RECHERCHEH($C$1;Feuil2!$A$1:$M$2;2;FAUX);"")
et cela devrait solutionner votre problème
Messages postés
15
Date d'inscription
lundi 15 septembre 2003
Statut
Membre
Dernière intervention
3 août 2016
1
vous allez finir par me trouvez chiant...

la formule fonctionne que si la date fin de mois est en C6
dans mon cas les dates ne sont pas attribuée à une cellule fixe
(c'est un plannig sur 1 semaine détaillant les clients vu par jour)
le 31/01/13 peut etre en C6 ou C7 ou C22 suivant le nombre de client

je vais regarder ça après mangé, avec le nombre de formules que j'ai ici je dois pouvoir faire quelque chose
Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 130
Mais non mais non, c'est juste que vous ne lisez pas tout ce que l'on vous écris!
Soit ici pour mémoire:
https://forums.commentcamarche.net/forum/affich-27097369-copier-cellule-seulement-si-date-identique#7

Ci dessous votre modèle avec une solution (qui donne 400 et non pas 4000, vu qu'il s'agit du 31/3)

https://www.cjoint.com/c/CBjnbY9Hbyp

Mais pour mémoire quand même:
vos messages parlent de la colonne C avec C1 et un résultat en D1
votre modèle fait commencer la liste en C6 et renvoie la résultat en E14

Toutes les contraintes étaient notées dans mon dernier modèle, mais ça a du vous échapper!!
Rien d'étonnant avec ça que vous ne vous en sortiez pas.

crdlmnt
Messages postés
15
Date d'inscription
lundi 15 septembre 2003
Statut
Membre
Dernière intervention
3 août 2016
1
vous avez raison je vais revoir tout ca au calme
Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 130
C'est raisonable. Voyez quand même le fichier joint à mon dernier message.
Crdlmnt. Bonne chance
Messages postés
5724
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
1 décembre 2021
675
bonjour

la cellule C6 est la première de la liste et je cherche la date fin mois, je ne pense pas qu'il puisse avoir 2 fin de mois dans une semaine
Messages postés
15
Date d'inscription
lundi 15 septembre 2003
Statut
Membre
Dernière intervention
3 août 2016
1
Vaucluse je te remercie pour toutes ces formules
mais je n'y arrive pas
meme avec ton fichier xls

dans ta feuille de calcul on part du 26/01 en C6, le 31/01 arrive en C9, le résultat en E14 affiche 400 alors qu'il devrait afficher 4000

Si les dates sont espacées par des cellules vides, visiblement ça ne fonctionne pas

J'ai bien l'impression qu'il y a trop de contraintes à gérer dans ce cas

Je ne vais pas prendre plus de votre temps

encore merci pour vos réponses

je marque en resolu

cdt
Messages postés
5724
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
1 décembre 2021
675
votre fichier avec les formules

https://www.cjoint.com/?3BjoNcIQpHo
Messages postés
15
Date d'inscription
lundi 15 septembre 2003
Statut
Membre
Dernière intervention
3 août 2016
1
Merci