Calcul du DIF

Résolu/Fermé
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013
- 22 janv. 2013 à 16:12
 axions - 23 janv. 2013 à 17:24
Bonjour à tous,

Je souhaiterai obtenir de l'aide sur une formule de calcul de DIF.

Voila, dans ma société le DIF (droit individuel de formation) se calcul comme suivant l'exemple :

Un gars arrive le 01/09/2010 et au 31/12/12 il à droit à 26h68 de DIF.

En fait, la première année, le salarié ne bénéficie pas du DIF (car ancienneté inférieure à 1 an) et la deuxième année, il acquiert 20 heures de DIF proratisées selon sa date d'entrée.

Quelqu'un serait t-il capable de m'expliquer cette formule ?

Merci par avance pour votre aide !

Meilleures salutations.

Laure


3 réponses

Bonsoir,

une fonction cachée d'Excel reste pourtant bien pratique : DATEDIF()
cette fonction non explicitée calcule la différence entre 2 dates, soit par jours, par mois ou par année(s), mais avec une syntaxe en anglais :
' =DATEDIF(date 1;date2;"d") pour les jours (day) ou "m" pour mois, ou encore "y" pour année (year)
de plus, cette fonction tient compte des années bissextiles.

donc la formule demandée peut s'écrire :
' =SI(DATEDIF(A2;B2;"y")<1;0;20*(B2-A2-365)/365)

dans laquelle : si la durée est inférieure à 1 an ==> valeur = 0
les 20 euro sont au prorata de la seconde année et acquis à chaque suivante.

si l'employé est rentré le 28/2/2008 et parti le 28/2/2009, il aura quand même droit à 0.055 € (pour le 366e jour)
car le calcul doit lui être présenté au plus avantageux (normalement)

Bonne suite
Cordialement
1
re:
il convient, bien sûr, de remplacer les Euro par des heures, calculées en centièmes d'heure
0