Compter un nombre de cellules sur plusieurs colonnes avecritères

[Résolu/Fermé]
Signaler
-
Messages postés
2496
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
6 octobre 2021
-
Bonjour

Voici mon souci: je dois compter le nombre de cellules dans lesquelles le texte "Satisfait" apparaît en fonction de plusieurs critères (si colonne A contient "X" et si année dans colonne B est 2012 par exemple.

Dans ce exemple: pour l'entité "X" en 2012, 5 réponses "Satisfait" recensées
Pour "Y" en 2012: 1 réponse


A B C D E F G H

X 02/03/2012 Nom1 Satisfait Nom2 Peu satisfait Nom3 Satisfait
X 03/10/2012 Nom1 Satisfait Nom2 satisfait Nom3 Satisfait
Y 03/06/2012 Nom4 Satisfait
Y 07/06/2012 Nom4 Peu satisfait



Merci de votre aide


2 réponses

Messages postés
2496
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
6 octobre 2021
1 001
Bonjour,
Un "SommeProd" convient à cette application:
=SOMMEPROD((A2:A12="X")*(ANNEE(B2:B12)=2012)*((D2:D12="Satisfait")+(F2:F12="Satisfait")+(H2:H12="Satisfait")))

On peut noter que le + intervient comme un OU.

Les critères pourraient être saisis dans des cellules J2, K2, L2.
La formule devient:
=SOMMEPROD((A2:A12=$J2)*(ANNEE(B2:B12)=$K2)*((D2:D12=$L2)+(F2:F12=$L2)+(H2:H12=$L2)))
Effectivement je n'avais pas intégré le "+" ....
Merci pour votre retour. Ça fonctionne!
Bonne soirée!
Messages postés
2496
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
6 octobre 2021
1 001
La proposition d'eriiic est plus performante: 2 termes de moins pour le même résultat!
Messages postés
24198
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 927
Bonjour à tous,

que l'on peut simplifier un peu en :
=SOMMEPROD((A2:A5="X")*(ANNEE(B2:B5)=2012)*(C2:I5="satisfait"))

eric