Bouton submit inactif sans raison

[Résolu/Fermé]
Signaler
-
Messages postés
149
Date d'inscription
lundi 12 novembre 2012
Statut
Membre
Dernière intervention
30 octobre 2013
-
Bonjour,

J'ai développé une page toute simple avec 2 boutons submit, et l'un comme l'autre sont inactifs, lorsqu'on clique dessus, ça sélectionne le texte...
J'ai tenté webkit-user-appearance: button, webkit-user-select: none, mais rien n'y fait...
C'est la dernière touche au développement du site, je dois lel ivrer demain soir, alors si quelqu'un pouvait m'aider, ça serait génial!!!
Merci d'avance!!



5 réponses

Messages postés
6528
Date d'inscription
vendredi 15 janvier 2010
Statut
Membre
Dernière intervention
31 juillet 2021
1 564
slt

et ton code ?
comment veux tu avoir une réponse sans rien du tout !
Messages postés
149
Date d'inscription
lundi 12 novembre 2012
Statut
Membre
Dernière intervention
30 octobre 2013
4
bien dis, c'est vrai que sans code, ont peux pas t'aider l'ami ;)
Je ne comprends pas, je l'ai ajouté hier soir, mais apparemment mon message n'a pas été enregistré..
Le voici, mais je doute qu'il soit riche d'infos, d'autant qu'il est pris dans une page entière (vous voulez toute la page ?)

<div id='content' role='main' class="quel-crado-etes-vous">
         <div id='stop'>
<p>Vous avez déjà fait ce test avant de vous inscrire.</p> 
Voulez-vous qu'on reprenne votre profil comme base de vote coaching, ou préférez-vous recommencer ?

 <form method="post" action="">
       <input class="boutgr" name='recup' value="Récupérez mon test" />
        <input class="boutgr" name='go' value="Je recommence" />
  </form>
</div> <!-- #stop --->
</div><!-- #content -->


Pour info, il y a action="" parce qu'il y a un $PHP_SELF; qui n'affiche rien dans le code html.

Et voici le style pour mes boutons:

input
{
  margin-top: 0px;
  margin-right: 5px;
  margin-bottom: 5px;
  margin-left: 0px;
}

.boutgr, .boutpet
{
  border-top-left-radius: 10px;
  border-top-right-radius: 10px;
  border-bottom-right-radius: 10px;
  border-bottom-left-radius: 10px;
  height: 30px;
  text-align: center;
}

.boutgr
{
  background-color: #7dc61e;
  border-top-width: 1px;
  border-right-width-value: 1px;
  border-bottom-width: 1px;
  border-left-width-value: 1px;
  border-top-style: solid;
  border-right-style-value: solid;
  border-bottom-style: solid;
  border-left-style-value: solid;
  border-top-color: #73aa1d;
  border-right-color-value: #73aa1d;
  border-bottom-color: #73aa1d;
  border-left-color-value: #73aa1d;
  border-image-source: none;
  border-image-slice: 100% 100% 100% 100%;
  border-image-width: 1 1 1 1;
  border-image-outset: 0 0 0 0;
  border-image-repeat: stretch stretch;
  color: #ffffff;
  font-size: 120%;
}

.boutgr:hover
{
  background-color: #73aa1d;
  color: #ffffff;
}

input.boutgr
{
  cursor: pointer;
}



Ce sont des boutons que j'utilise sans problème à plein d'autres endroits du site, mais là, ça ne veut rien entendre... :-(

Merci d'avance! :-)
Messages postés
149
Date d'inscription
lundi 12 novembre 2012
Statut
Membre
Dernière intervention
30 octobre 2013
4
met :

type=submit

ici

<form method="post" action="">
<input class="boutgr" name='recup' value="Récupérez mon test" />
<input class="boutgr" name='go' value="Je recommence" />
</form>

Pour tes 2 boutons.
Ah mais oui.... évidemment!! Je n'ai plus les yeux en face des trous après une centaine d'heures de dév... lol
Merci beaucoup (oui, ça marche, bien sûr !!)
Messages postés
149
Date d'inscription
lundi 12 novembre 2012
Statut
Membre
Dernière intervention
30 octobre 2013
4
au plaisirs ;)
et, au cas où

#stop form
{
  text-align: center;
  position: absolute;
  top: 120px;
  width: 100%;
  z-index: 5000;
}


#stop
{
  margin-top: 100px;
  margin-right: 0px;
  margin-bottom: 20px;
  margin-left: 0px;
  width: 100%;
  text-align: justify;
  font-size: 110%;
}



Je ne vois rien de particulier qui soit en rapport avec l'inactivité des boutons, vous si?