Fonction SI

Fermé
P'tit Rem Messages postés 1 Date d'inscription jeudi 29 novembre 2012 Statut Membre Dernière intervention 29 novembre 2012 - 29 nov. 2012 à 12:04
Raymond PENTIER Messages postés 58496 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 14 juin 2024 - 27 déc. 2012 à 00:39
Bonjour,
J'ai un soucis avec une formule.
Dans A3, il y a une cellule libre d'écriture.
Dans AK3, il y a en plus de 2 fonctions "SI", un "texte perso" (voir : Format de cellule / Nombre / Catégorie : Personnalisée "TEXTE PERSO"#).
Je souhaite mettre une formule dans AK3, tel que : Si :
- Il n'y a rien dans A3, alors, il ne doit rien y avoir dans AK3.
- Il y a une valeur (ex : 7" / 4"1#4 / 18") dans A3, il faut afficher le résultat de la ligne de calcul3 dans AK3.
Est-ce possible ?
Merci d'avance.
Ptit'Rem.

3 réponses

PHILOU10120 Messages postés 6385 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 11 juin 2024 802
29 nov. 2012 à 12:23
Bonjour

Pour tester si A3 est vide mettre dans la formule

=si(a3="";"";la cellule ou est le résultat du calcul ligne3)
0
Senioritta Messages postés 27 Date d'inscription jeudi 29 novembre 2012 Statut Membre Dernière intervention 6 juillet 2015
29 nov. 2012 à 12:32
Bonjour

ta question n'est pas clair je n'ai pas bien compris néaumoins je vais essayé de proposer des solutions d'apres ce que j'ai compri.

pour tester si une celluse est vide: tu peux soit utiliser la fonction nbcar() elle compte le nombre de caractère d'une cellule si c'est vide elle retourne 0 ou bien si a3=""

donc ds B3 tu met : =SI(NBCAR($A$3)=0;" ";$A$3/2) et tu glisse juska la colonne K

le 3eme champs veut dire sinon (si c pa vide) diviser A3 par deux (c juste un exemple de fonctions)

Bon courage
0
Raymond PENTIER Messages postés 58496 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 14 juin 2024 17 132
27 déc. 2012 à 00:39
Alors, Ptit'Rem, ça y est ? c'est bon ?
0