Excel recherche valeur directement superuieure et pas egale

[Résolu/Fermé]
Signaler
Messages postés
4
Date d'inscription
mardi 20 novembre 2012
Statut
Membre
Dernière intervention
8 novembre 2013
-
Messages postés
4
Date d'inscription
mardi 20 novembre 2012
Statut
Membre
Dernière intervention
8 novembre 2013
-
Bonjour,

J ai un champs de valeur a décimale sur trois colonne B4 a D51.

en cellule C56 je reporte ma valeur minimum (MIN(B54:D51)

En C57 j aimerai reporter la valeur directement supérieur a la valeur minimum reporté en C56, mais j ai des valeurs égales dans mon champs donc la formule (PETITE.VALEUR(B$4:D$51;2) ne marche pas puisqu'elle me reporte la 2eme valeur qui est en fait égale a la première.
J ai essayé : =SI(PETITE.VALEUR(B$4:D$51;2)>C56;(PETITE.VALEUR(B$4:D$51;2));(PETITE.VALEUR(B$4:D$51;3)))
mais ça ne marche pas j ai trop de valeur égales. ( trois fois la même valeur donc 3eme valeur égale a la 1ere)

est ce que quelqu'un a une solution s il vous, plait
(sachant que j'aimerai aussi reporter la 3eme valeur directement supérieure.

4 réponses

Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 779
Où est ton fichier ?
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 090
Bonsoir
peut être avec:

=PETITE.VALEUR(B4:D51;NB.SI(B4:D51;MIN(B4:D51)+1)
(solution "tous types"

ou alors dans votre cas en C57:
=PETITE.VALEUR(B4:D51;NB.SI(B4:D51;C56)+1)
puisque C56 ressort déja le mini

crdlmnt

ne sommes nous pas seuls à comprendre ce que l'on explique?
Messages postés
4
Date d'inscription
mardi 20 novembre 2012
Statut
Membre
Dernière intervention
8 novembre 2013

Impeccable eric merci beaucoup.
Je t'avouerais que je comprend pas exactement la formule mais ça marche et ça m'aide beaucoup.
Messages postés
24202
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 937
Bonsoir à tous,

Une méthode générale quelque soit le nombre de valeurs min sans doublon voulues.
Plus la proposition de vaucluse étendue à la 3ème valeur.

https://www.cjoint.com/?BKuuXr0D0PR

eric