Erreur formule multiple SI avec >=

[Résolu/Fermé]
Signaler
Messages postés
2
Date d'inscription
mardi 13 novembre 2012
Statut
Membre
Dernière intervention
13 novembre 2012
-
Messages postés
2
Date d'inscription
mardi 13 novembre 2012
Statut
Membre
Dernière intervention
13 novembre 2012
-
Bonjour,

Il semblerait qu'il y ait une erreur dans ma formule mais je ne vois pas où:
=SI(B17>=1000;B17*0,05;SI(B17>=3000;B17*0,1;SI(B17>=5000;B17*0,15;SI(B17>=7000;B17*0,2;SI(B17>=9000;B17*0,25;SI(B17>=11000;B17*0,3;SI(B17>=13000;B17*0,35;SI(B17>=15000;B17*0,4;))))))))

Quelle que soit la valeur de B17, la formule calcul B17*0.05 ...

Merci de votre aide

3 réponses

Messages postés
26184
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 septembre 2021
6 052
Bonjour

c'est normal, puisque Excel va s'arrêter à la 1° solution trouvée dans la liste des conditions
Si vous commencez par >1000 tout ce qui est > 1000 sera exécuté sur le 1° calcul
Réécrivez votre formule en modifiant la hiérarchie et en commençant par
B7>=15000;B17*0,4;SI etc......en descendant.

crdlmnt



ne sommes nous pas seuls à comprendre ce que l'on explique?
Messages postés
117
Date d'inscription
dimanche 23 janvier 2011
Statut
Membre
Dernière intervention
11 avril 2019
40
Bonjour ,

L'erreur n'est pas dans la formule, mais dans la façon de gérer les nombres !!!
En effet quelque soit le chiffre en B17 (> à 1000) la première condition est remplie donc la valeur est toujours multipliée par 0.5. !!

Inverse les valeurs en commençant par SI( B17 >=15000;B17*0.4; SI() .....

Cordialement
Gilles
Messages postés
2
Date d'inscription
mardi 13 novembre 2012
Statut
Membre
Dernière intervention
13 novembre 2012

c'est tellement logique !! Merci tout fonctionne.