Calculer l'écart moyen entre 2 dates consécutives [Résolu/Fermé]

Signaler
-
Messages postés
23588
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2020
-
Bonjour,

Je bosse sous Excel 2010.
J'ai une série de produits (réprésentons les par A, B, C, ...) et pour chacun de ces produits j'ai plusieurs dates de commandes de ce produit sur un horizon de deux mois.
Exemple:
Le produit A a été commandé les
23/08/2012
27/08/2012
30/08/2012
03/09/2012
05/09/2012
07/09/2012
12/10/2012
15/10/2012

Je voudrais calculer l'écart moyen entre deux dates consécutives.
Je veux pouvoir dire, on a reçu une commande pour le produit A sur les deux derniers mois en moyenne tous les X jours.
L'idéal serait d'insérer ce calcul dans mon tableau croisé dynamique pour qu'en face de chaque produit (A, B, C...) je puisse afficher le résultat.

J'ai essayé de mettre les dates sous forme de Nombre (la référence étant au 1/1/1900 je crois) mais je n'y arrive pas

HELP !!! :)
merci d'avance

3 réponses

Messages postés
8212
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
22 octobre 2020
1 498
Bonjour,

Formule :
=(MAX(A1:A8)-MIN(A1:A8))/(NB.SI(A1:A8;">0")-1)
mettre la cellule au format nombre
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

en fait je voudrais calculer l'écart moyen entre deux dates consécutives.
je ne vois pas que vous l'ayez pris en compte dans votre formule, je me trompe ?
Messages postés
23588
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2020
6 421
Tu as une autre réponse en-dessous.
Je trouve la même chose que patrice...
Essaie et si tu n'es pas d'accord sur le résultat explique pourquoi et ce que tu attends comme réponse..

eric
non mais en fait c bon c le bon résultat nickel sauf que je ne comprends pas la deuxième formule d'eriiic (matricielle)

par contre savez vous comment insérer la première dans mon tableau croisé dynamique ? J'ai une colonne produits (A, B, C...) et la collone d'après ce sont les dates...
insérer élément calculé ?
merci d'avance
Messages postés
23588
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2020
6 421
Bonjour,

ou bien :
=MOYENNE(A2:A8-A1:A7)
formule matricielle à valider par shift+ctrl+entrée

eric
Messages postés
23588
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2020
6 421
Re,

sauf que je ne comprends pas la deuxième formule d'eriiic (matricielle)
=MOYENNE(A2:A8-A1:A7)
fait la moyenne de A2-A1;A3-A2; etc
mais comme elle travaille sur des matrices et non des valeurs individuelles il faut la valider comme indiqué : shift+ctrl+entrée

Pour le reste le mieux est d'avoir le fichier sous les yeux.

eric

PS: ne te retiens pas pour dire merci pour les réponses..

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.