Formule à plusieurs critère [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
jeudi 11 octobre 2012
Statut
Membre
Dernière intervention
12 octobre 2012
-
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
-
Bonjour, j'aimerai que dans ex.: A1 ait le résultat 1 si B1
à pour valeur 1 ou vr ou vb mais que si la valeur dans B1 est vl ou vv ou vj
le résultat 1 apparaisse dans A2, merci pour votre aide.


NB: il y aurai environ 7 valeurs différentes pour un résultat

5 réponses

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
811
Salut le forum

Formule en A1
=SI(ESTNA(EQUIV(B1;{1;"vr";"vb"};0));"";1)
Formule en A2
=SI(ESTNA(EQUIV(B1;{"vl";"vv";"vj"};0));"";1)

Mytå
Bonsoir, Mytå

dsle pour la synchro
bonne nuit

Cordialement
Bonsoir,

en A1 : =SI(OU(B1=1;B1="vr";B1="vb");1;"")
en A2 : =SI(OU(B1="vl";B1="vv";B1="vj");1;"")

Bonne suite
Messages postés
52552
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
14 417
Yann, voudrais-tu expliquer ton NB, car aucun de nous n'a vu ce que tu voulais dire !

Par ailleurs, bien que ta discussion soit intitulée "Formule à plusieurs critères", tu as bien constaté qu'il faut plusieurs formules, une pour chaque cellule qui doit afficher un résultat ...

C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
Messages postés
5
Date d'inscription
jeudi 11 octobre 2012
Statut
Membre
Dernière intervention
12 octobre 2012

Bonjour,je vous remercie pour la rapidité à laquelle vous avez eu la gentillesse de me répondre.
axions je te remercie pour ton aide, c'est ce que je souhaitais


le NB était: il y aurai environ 7 valeurs différentes pour un résultat
mais cela n'a plus son importance actuellement.

J'avoue que je suis devant un autre dilemme je recherche une autre formule qui je pense sera plus complexe.
Je voudrais vous joindre un fichier excel qui vous permettra de mieux comprendre mon objectif, mais je ne sais comment faire.
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
811
Salut le forum

Pour joindre un fichier, tu envois ton fichier (sans données confidentielles)
sur https://www.cjoint.com/ , et tu recopies le lien obtenu à ton prochain message.

Tu n'aimais pas les formules que j'avais proposées.
Formule en A1
=SI(ESTNA(EQUIV(B1;{1;"vr";"vb"};0));"";1)
Formule en A2
=SI(ESTNA(EQUIV(B1;{"vl";"vv";"vj"};0));"";1)

Mytå
Messages postés
5
Date d'inscription
jeudi 11 octobre 2012
Statut
Membre
Dernière intervention
12 octobre 2012

rapide l'info merci, voici donc le fichier https://www.cjoint.com/?BJlpG76stVm
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
811
Salut le forum

Formule à recopier vers la droite
Pour Lundi - Matin
=SOMMEPROD((C$5:C$12={"v"."j"."b"."r"})*1) 
Pour Lundi - Repas
=SOMMEPROD((C$5:C$12={"j"."b"."r"})*1)
Pour Lundi - Sieste
=SOMMEPROD((C$5:C$12={"b"."r"})*1)
Pour Lundi - Après-midi
=SOMMEPROD((C$5:C$12={"r"})*1)

Mytå
Messages postés
5
Date d'inscription
jeudi 11 octobre 2012
Statut
Membre
Dernière intervention
12 octobre 2012

Bonjour Mytâ, je te remercie pour ta réponse mais il y a un problème, car lorsque je loue cette formule ex pour lundi une fenêtre d'erreur m'indique La formule entrée contient une erreur. Pour obtenir de l'aide sur la création, etc...
Si vous ne voulez pas taper de formule évitez d'utiliser le signe (=) ou le signe (-) etc....
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
811
Re le forum

Remplace le point par un antislash dans les formules
car ton séparateur décimal doit être le point.
=SOMMEPROD((C$5:C$12={"v"\"j"\"b"\"r"})*1)

Mytå
Messages postés
5
Date d'inscription
jeudi 11 octobre 2012
Statut
Membre
Dernière intervention
12 octobre 2012

Bonjour Mitå, je te remercie pour ton aide, pour l'intérêt que tu portes à m'aider mais je pense que cela ne s'adresse pas qu'à moi. C'est exactement ce que je recherchais, en fait ce n'est pas compliqué si l'on sais que signifie somme sommeprod nbval etc... J'aimerais savoir d'où tiens-tu ton savoir sur excel, j'ai toujours été autodidacte sur beaucoup de domaine y compris Excel, mais je n'ai jamais trouvé de livre permettant de maitriser Excel surtout dans le domaine des formules.

Question pourquoi ai-je du remplacer les . par \

Encore merci pour ton aide...salutation au Canadien
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
811
Re le forum

Tu as du remplacer le point par un antislash dans les formules
car ton séparateur décimal est le point au lieu de la virgule.

Mytå