Excel, somme avec condition [Résolu/Fermé]

Signaler
Messages postés
33
Date d'inscription
mercredi 6 février 2008
Statut
Membre
Dernière intervention
27 août 2015
-
Messages postés
33
Date d'inscription
mercredi 6 février 2008
Statut
Membre
Dernière intervention
27 août 2015
-
Bonjour,

Je veux additionner les quantités d'un même article dans une liste de plusieurs articles.
Ex :
colonne A type article (ecrou, rondelle, boulon)
colobbe B diametre art (3, 4, 8)
colonne C quantité de chaque article

case G4 = somme de tous les ecrous de diametre 3
case G5 = somme de tous les ecrous de diametre 4
case G6 = somme de tous les ecrous de diamètre 8

les articles sont pêle mêle dans la liste suivant l'ordre d'écriture.
J'ai essayé la formule "=Somme.Si.Ens()" mais ça ne me donne pas le calcul escompté...
Merci d'avance pour l'aide

Charlie

ps : je ne sais pas comment attacher mon fichier




10 réponses

Messages postés
23495
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2020
6 353
Bonjour,

pour déposer un fichier : cjoint.com et coller ici le lien fourni.
eric
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 249
Salut,

Pour joindre ton fichier, avec ce lien ce sera plus compréhensible

https://www.cjoint.com/
Messages postés
33
Date d'inscription
mercredi 6 février 2008
Statut
Membre
Dernière intervention
27 août 2015

Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 249
Re,

tu peux utiliser cette formule parmi d'autres,

=SOMMEPROD((B2:B100="tige fil.")*(D2:D100=8)*(E2:E100=294)*(C2:C100))

ou tu fais référence à des cellules contenant les critères de recherche
=SOMMEPROD((B2:B100=F1)*(D2:D100=G1)*(E2:E100=H1)*(C2:C100))

ou encore

=SOMME.SI.ENS(C2:C100;B2:B100;F1;D2:D100;G1;E2:E100;H1)

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
33
Date d'inscription
mercredi 6 février 2008
Statut
Membre
Dernière intervention
27 août 2015

Super ça fonctionne

Merci beaucoup, Mike-31

Charlie
Messages postés
33
Date d'inscription
mercredi 6 février 2008
Statut
Membre
Dernière intervention
27 août 2015

Dans la ligne "=SOMME.SI.ENS(C2:C100;B2:B100;F1;D2:D100;G1;E2:E100;H1) ", F1,G1,H1 correspondent à quoi ?
La formule recopiée telle quelle me renvoie 0
Merci
Charlie
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 249
Re,

Récupère ton fichier avec les deux propositions, en F1, G1 et H1 tu pourrais créer des liste de validations

https://www.cjoint.com/?BHztSJLPfrP
Messages postés
33
Date d'inscription
mercredi 6 février 2008
Statut
Membre
Dernière intervention
27 août 2015

Ok, là, j'ai compris.
Mais je veux inscrire les résultats sur le feuille2
Et puis-je dire à excel de colorier les cellules additionées (pour visualiser les oublis)
Merci encore
Charlie
Messages postés
23495
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2020
6 353
Bonsoir,

Mike étant au lit à 20h30 je me permet ;-)

Mais je veux inscrire les résultats sur le feuille2
tu sélectionnes F1:I3, tu coupes et tu colles où tu veux dans la feuille 2

Et puis-je dire à excel de colorier les cellules additionées (pour visualiser les oublis)
Ca serait compliquer pour rien, aucune raison qu'excel oublie qcq chose...
Par contre si sur une ligne tu écris "écrou" à la place d' "ecrou" il ne sera pas compté.

eric
Messages postés
33
Date d'inscription
mercredi 6 février 2008
Statut
Membre
Dernière intervention
27 août 2015

C'est vrai que ça serait compliqué pour rien, mais je ne voulais pas dire que excel oublie, ce serait plutôt moi qui oublierai un item ou l'autre...
bonne nuit
Charlie
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 249
Bonjour,

Je me couche tard et me lève tôt, mais hier soir je n'était pas sur l'écran.

Mais pourquoi faire simple lorsqu'on peut faire compliqué. exemple de ce qui est demandé sur ce fichier, colorisation en jaune des valeurs additionnées, affichage sur la feuille 1 ou 2 et liste de validation

https://www.cjoint.com/?BHAjbEYczYw
Messages postés
33
Date d'inscription
mercredi 6 février 2008
Statut
Membre
Dernière intervention
27 août 2015

Waouwwww,super travail....merci beaucoup....
On peut dire que tu connais Excel...bravo
Moi, j'ai 6 heures de décalage avec toi, pour ça que ça ne correspond pas toujours...
Je reste au Québec.
Merci encore pour ton aide
Bonne journée
Charlie