Demarrage de mysql sous fedora16

Résolu
Bonjour chers amis,

J'ai lu sur " http://doc.fedora-fr.org/wiki/Installation_et_configuration_de_MySQL " que

mysql est intégré dans Fedora16 mais néanmoins j'ai utiliser "yum install mysql-server". Il

n'y a eu que des mise à jours.

Mon problème est que je n'arrive pas à le démarrer. j'ai utiliser plusieurs commande mais

ca ne marche pas.

Pour la commande "service mysqld start", voici le message qui s'affiche: " Redirecting to /bin/systemctl start mysqld.service Job failes. See system logs and 'systemctl status' for details
J'ai essayer de voir mais je ne comprends rien.

Pour la commande "su -lc 'service mysql start" voici le message qui s'affiche est pareil.

SVP aidez moi. Comment pouvoir rendre fonctionnel mysql??

Merci d'avance

3 réponses

  1. Contributeur
    bonjour,
    tu tapes
    systemctl status mysqld.service
    et tu verra ou est l'erreur , si tu sais pas dechifrer
    colle le ici
    a+
    1
    1. merci Jeanbi

      la commande "systemctl status mysqld.service" donne:


      mysqld.service - MySQL database server
      Loaded: loaded (/lib/systemd/system/mysqld.service; disabled)
      Active: inactive (dead)
      CGroup: name=systemd:/system/mysqld.service
      [root@ben ~]#


      Je ne comprends pas biensur. merci d'avance
      0
    2. Contributeur
      re,
      Attention !
      Nom du serveur
      
      Avant de lancer MySQL, il faut s'assurer que la machine possède un nom (et surtout pas le localhost proposé lors de l'installation. On peut utiliser la commande hostname pour vérifier et changer temporairement. On utilise la commande system-config-network (onglet DNS) pour un changement permanent 

      a part peut etre ceci sinon je trouve pas pourquoi le sercice ne demarre pas ,
      as tu installer apache ?
      a+
      0
    3. oui j'ai installer appache et il demarre sans problème.
      J'avais deja changer le nom de ma machine .

      en fait voici ce que je viens d'essayer et voilà le resultat

      [root@ben ~]# cd /etc/init.d/

      [root@ben init.d]# mysql start

      ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

      [root@ben init.d]#

      Merci de m'aider
      0
    4. ok je vais voir mon grand
      merci.
      0
  2. lolo45787 bonjour svp je n'ai pas compris ce que vous voulez dire
    merci
    0
    1. J'ai réussi a le démarrer après avoir mis tout le système à jour.
      Merci a tous
      0