Excel 2010 afficher un classement

Résolu/Fermé
Messages postés
4
Date d'inscription
dimanche 12 août 2012
Statut
Membre
Dernière intervention
12 août 2012
-
Messages postés
4
Date d'inscription
dimanche 12 août 2012
Statut
Membre
Dernière intervention
12 août 2012
-
Bonjour à tous,

Je souhaite attribuer un rang à des sites commerciaux selon le taux de traitement d'opportunités commerciales en %. La formule rang m'affiche des valeurs qui ne se suivent pas : le classement passe de 1 à 10 par exemple. Est ce que quelqu'un connait le problème ?

Merci d'avance, si besoin je vous envoie le fichier.

Bon dimanche !

3 réponses

Messages postés
4
Date d'inscription
dimanche 12 août 2012
Statut
Membre
Dernière intervention
12 août 2012

Merci vil coyote d'avoir déplacé ma question, j'étais justement en train de me dire que je ne l'avais pas mise au bon endroit !
Concernant ma question, je comprends le pb, ma colonne taux de traitement qui sert de base au classement contient plusieurs valeurs % égales. donc excel classe en 1 ex-aecquo les valeurs % égales, mais passe directement au rang 10 lorsque l'on passe à une valeur % différente, car c'est la 10 ème valeur de la liste de base.
Est ce que quelqu'un sait comment faire pour avoir un classement avec des rangs qui se suivent ? ex : si j'ai 10 valeurs 100%, elles doivent être toutes classées 1eres, mais la 1ère valeur différente doit être classée 2ème.
J'espère avoir été claire !
Merci d'avance
Messages postés
10745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
26 janvier 2022
1 250
Bonjour,
Essayer cette formule en [B2] :
=SOMME(--(A3<SI(EQUIV(maplage;maplage;0)=LIGNE(INDIRECT("1:"&LIGNES(maplage)));maplage;0)))+1
Formule matricielle à valider avec Ctrl+Shift+ Enter
A tirer vers le bas
Plage à traiter en % nommée : maplage = [A2 :A12]
Messages postés
4
Date d'inscription
dimanche 12 août 2012
Statut
Membre
Dernière intervention
12 août 2012

Merci Le Pingou,

Entre temps, j'ai toruvé cette formule matricielle : =SOMME(SI(plage concernee>cellule selon laquelle on établit le rang;1/NB.SI(plage concernee;plage concernée)))+1
J'indique la plage concernée en saisissant : 1 ere cellule de la plage en haut à gauche:derniere cellule de la plage en bas à droite.

Cette formule marche très bien.
Si cela peut servir...

Bon après midi !