Somme si + valeurs positives uniquement [Résolu/Fermé]

Signaler
-
Messages postés
12184
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
31 juillet 2020
-
Bonjour,

Je souhaite mettre en place une fonction somme.si (excel 2003) la formule fonctionne bien avec le 1er critère or je souhaite n'avoir la somme si que des valeurs positives c'est la que j'ajoute un 2e critère qui j'imagine doit être >0 mais la formule ne fonctionne pas cmt dois je procéder ?

4 réponses

Messages postés
12184
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
31 juillet 2020
2 467
Alors essaie ceci :
=SOMMEPROD(K12:K5000*(B12:B5000=DM9)*(K12:K5000>0))
Somme des nombres de K12àK5000 si en B on a le même nombre qu'en DM9 et si K est supérieur à 0...


ps : attention en utilisant SOMMEPROD. Plus votre plage est longue, plus la formule va être gourmande et donc lente...
Respecter également la longueur des matrices. K12:K500 et B12:B5000 = matrices de même longueur, ça fonctionne...
Cordialement,
Franck P
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57450 internautes nous ont dit merci ce mois-ci

Messages postés
12184
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
31 juillet 2020
2 467
Bonjour,
Ne connaissant pas ton premier critère, j'ai imaginé une formulequi ferait la somme des nombres compris entre A1 et A12, critère 1 : <9, critère 2 : > 0. Ca donne :
=SOMMEPROD(A1:A12*(A1:A12<9)*(A1:A12>0))
Bonjour,

j'ai testé la formule mais je n'ai pas le bon résultat ça m'inscris 0
mon 1er critère est =SOMME.SI($B$12:$B$65536;DM9;$K$12:$K$65536)
DM9=un chiffre que je vais chercher dans la plage B....
les données à additionner sont dans la colonne k....... mais dans K j'ai des nombres + et des nombres - et je n'arrive pas exclure les nombres - de ma somme
merci beaucoup je en savais pas qu'il fallait que mes tables matrices soient de même longueur !!
ça fonctionne.
Messages postés
12184
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
31 juillet 2020
2 467
De rien.
A+ et bonne fin de journée.