Excel 2007 : Jours Feriés sous Excel [Résolu/Fermé]

Signaler
Messages postés
14
Date d'inscription
mercredi 13 juin 2012
Statut
Membre
Dernière intervention
21 juin 2013
-
Messages postés
14
Date d'inscription
mercredi 13 juin 2012
Statut
Membre
Dernière intervention
21 juin 2013
-
Bonjour à tous ,


Est il possible qu'EXCEL , trouve les jours Feriés dans une feuille de calcul d'une période dans une feuille de calcul .
Exemple du : 01/12/12 au 31/12/12.
A savoir Chaque colonne est egale a une journée.
Donc pour cet exemple la periode commence le 1 jour de décembre au dernier, soit 31 colonnes

Les jours fériés doivent bien apparaitre dans la feuille de calcul , mais ne seront pas comptablisés.

Merci de votre aide et a bientot ,
Courtoisement

PHIL

3 réponses

Messages postés
25751
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
5 715
Bonjour
tout dépend de ce que vous voulez faire et que vous ne dites pas.
Si c'est pour compter un nombre de jours ouvrables entre deux dates, il; faut:
1° faire une liste des jours fériés en hors champ par exemple de X1à X20
Utiliser la,formule:
=NB.JOURS.OUVRES(Cell date début;cell date fin; X1:X20)
qui ne compte ni les samedi ni les dimanches ni les jours qui sont dans la liste.
crdlmnt
Messages postés
14
Date d'inscription
mercredi 13 juin 2012
Statut
Membre
Dernière intervention
21 juin 2013

Bonjour et merci de votre aide .
Voici un exemple avec plus de détail.

De la periode du 1 au 31 decembre, il y a deux jours feriés le 25 et 31 .
Je desirai que par une manip sur cette periode , Excel me retrouve les deux jours feriés et me les distingue dans la feuille .

Donc si je me positionne en A1 qui correspond au 1 decembre jusque la colonne 31 qui correspond au 31 decembre ,comment faire pour qu'il puisse reconnaitre les deux jours feriés du 25 et 31 decembre et me les distingue des autres jours .

Avez vous une solution , s'il vous plait

Courtoisement

PHIL
Messages postés
25751
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
5 715
Re
Si les distinguer, c'est par exemple modifier le format de la cellule, vous pouvez utiliser une mise en forme conditionnelle, mais il faudra toujours faire quelque part la liste de vos jours fériés
donc je reprend mon exemple avec la liste des jours fériés en X1:X20

si vous voulez cette liste sur une autre feuille, nommer le champ X1:X20, pour l'exemple le nom :> JF (c'est impératif pour la MFC)

Ensuite sélectionnez votre champ de date de A1 à AE1
et selon l'age de votre excel

avant 2007:
barre d'outil / Format / mise en forme conditionnelle

à partir de 2007
Ruban / Accueil / Paragraphe style / Mise en forme conditionnelle / Gérer les règles / Nouvelle régle

dans les deux cas chercher la rubrique "la formule est" ou "utiliser une formule"
Entrer cette formule:
=NB.SI(JF;A$1)
qui détectera si la date existe dans la liste JF
Cliquez sur format / Choisissez couleur de fond ou police à votre goût
et fermer par OK et OK

La formule va s'ajuster automatiquement sur A1,B1,C1 etc......Il suffit d'entrer celle correspondant à la 1° cellule du champ sélectionné

crdlmnt



ne sommes nous pas seuls à comprendre ce que l'on explique?
Messages postés
14
Date d'inscription
mercredi 13 juin 2012
Statut
Membre
Dernière intervention
21 juin 2013

Bonjour ,

Je viens de tester mais cela ne fonctionne pas ,je vous joint un fichier de test pour mieux me faire comprendre.

https://www.cjoint.com/?BGmjZl1XYgi

Encore merci pour votre aide et bonne journée

Phil
Messages postés
25751
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
5 715
Bonjour

vous n'aviez pas dit qu'il y avait plusieurs lignes....!

dans la formule de MFC enlevez le devant le $ dans A1 soit:
=NB.SI(JF;A1)

et dans les limites de champs affichées à droite, entrez:
=$A$1:$Q$3

ou Qxx avec xx selon les dimensions du tableau
donc 1° cellule en haut à gauche et dernière en bas à droite

crdlmnt
Messages postés
14
Date d'inscription
mercredi 13 juin 2012
Statut
Membre
Dernière intervention
21 juin 2013

Hello ,

Que voulez vous dire par : Dans les limites de champs affichées à droite, entrez:
=$A$1:$Q$3
ou Qxx avec xx selon les dimensions du tableau
donc 1° cellule en haut à gauche et dernière en bas à droite

Désolé pour le derangement

Courtoisement
Messages postés
25751
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
5 715
Voyez avec les explications ici
et revenez si ça ne convient pas.
https://www.cjoint.com/?BGmloH3p6Gi
crdlmnt
Messages postés
14
Date d'inscription
mercredi 13 juin 2012
Statut
Membre
Dernière intervention
21 juin 2013

Un Grand merci de votre aide , cela fonctionne exactement comme je le desirais.

Bonne journée et peut etre à bientot

PHIL