Séparateur sous excel 2010 [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
mercredi 4 juillet 2012
Statut
Membre
Dernière intervention
5 juillet 2012
-
 Émilie -
Bonjour,




J'ai un gros soucis de débutant. On vient de migrer sous excel 2010 et les séparateurs ne sont pas les mêmes que sous excel 2003 ( enfin j'ai l'impression).
En gros, quand j'ouvre un fichier il me mets toutes les données dans la première colonne: ils ne reconnait pas les virgules comme séparateur (; par défaut sur mon PC).
Alors je suis obligé à chaque fois de passer par Donnée-> convertir ......mais quand je sauvegarde le fichier il me remplace les virgules par des points virgules. Ce qui ne m'arrange pas vraiment parce que je parcours le fichiers en C++ et je fractionne les lignes en pointant sur les virgules.

J'ai bien vérifier que j'utilise les mêmes config de langue et tout.

y a il quelqu'un qui a le même problème?


Merci d'avance.

6 réponses

Messages postés
23380
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 juillet 2020
6 229
Bonjour,

tu vas dans le panneau de configuration, 'région et langue'.
Dans 'format / paramètres supplémentaires' :
- tu mets en 'symbole décimal' le . au lieu de la , (à changer aussi dans 'symbole monétaire')
- dans 'séparateur de liste' tu mets , au lieu de ;

Tu testes tes importations et tu reviens nous dire si c'est mieux.

eric
22
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61921 internautes nous ont dit merci ce mois-ci

Cool! Merci!
Messages postés
23380
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 juillet 2020
6 229
Bonsoir,

Tu n'aurais pas changé de version windows en même temps, et passé d'une version anglaise à une version française ?

Le séparateur de paramètres des formules est le séparateur de liste défini dans les paramètres régionaux.
Une , en anglais et un ; en français (la virgule étant par défaut le séparateur décimal en france)

eric
Messages postés
4
Date d'inscription
mercredi 4 juillet 2012
Statut
Membre
Dernière intervention
5 juillet 2012
1
Bonjour Eric,

Tu es un chef!! ça marche parfaitement!

L'imbécile heureux que je suis changeait les config dans l'onglet emplacement et pas dans format!

Encore merci Eric, tout ça va me faciliter la vie.


Bonne journée.
Messages postés
23380
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 juillet 2020
6 229
ok, je met en résolu pour toi.
eric
Messages postés
4
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
25 septembre 2013
1
Bonjour,

J'ai le même problème.

J'ai passé de Excel français à anglais et les fichiers csv que je télécharge s'ouvrent sous forme de texte alors que mes collègue ont des fichiers directement mis en forme dès l'ouverture (ils sont restés sur excel français mais je tiens à conserver ma version anglaise).

J'ai changé le séparateur de liste (pour ";" et pour "|") dans les paramètres régionaux mais rien n'y fait, les .csv s'ouvrent toujours avec des virgules comme séparateurs. Et dès que j'ai une cellule avec du texte contenant une virgule, ça me crée une colonne en trop (après avoir mis en forme manuellement).

Quelqu'un sais pourquoi le séparateur reste toujours la virgule ?

Merci
Messages postés
23380
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 juillet 2020
6 229
Bonjour,

Remet le séparateur de liste à ";", il n'est pas concerné et tu risques des ennuis.
C'est le séparateur décimal qu'il faut changer, mettre la virgule ou le point selon ton besoin.
Et dans les options excel il faut que 'Utiliser les séparateurs système' soit coché.

eric
Messages postés
4
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
25 septembre 2013
1
Ça ne change rien,

J'utilise les séparateurs système, les séparateurs de colonnes du fichier csv ne changent pas, c'est toujours la virgule même après avoir changé les paramètres de format. Et j'ai le point en séparateur décimal.
Messages postés
23380
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 juillet 2020
6 229
Bonjour,

J'avais mal lu, je pensais que tu parlais de séparateur décimal comme tu disais s'ouvrent sous forme de texte.
Quoiqu'il en soit ça ne change pas le début de ma réponse, le séparateur de liste concerne la séparation des paramètres des fonctions, des listes de validation, ...
En attendant mieux renommer le fichier en .txt avant de l'ouvrir (ou bien 'données / convertir...' après ouverture).
Tu n'as pas précisé ta version excel.

eric
Messages postés
4
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
25 septembre 2013
1
Bonjour et merci pour ton aide.

J'ai Excel 2007 avec Office Pro.
le .txt ne change rien.

la conversion manuelle pourquoi pas mais dès que j'ai un texte avec une virgule dans une cellule ça casse tout et il me manque des données.

Et sinon j'ai envoyé un csv, que j'avais téléchargé, à un collègue et il n'a pas pus l'ouvrir correctement alors qu'il le peut parfaitement quand c'est lui qui télécharge.

(pour info c'est une base de données de l'entreprise qui crée ces fichiers csv mais je suppose qu'au moment de la création, il doit y avoir une interaction avec les paramètres du pc. Sinon mon collègue aurais pus ouvrir mon fichier)

Il faut que j'essaye avec ma session sur un autre ordi pour voir.
Messages postés
4
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
25 septembre 2013
1
Ok c'est réglé, mon problème venait de Firefox, ça marche avec IE ...
Messages postés
4237
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 231
bonjour,

logiquement le remplacement des virgules par des points-virgules ne se fait que dans Excel. C'est à dire que si tu ouvres ton fichier avec le bloc notes ou Notepad ou autre éditeur de texte, tu devrais bien retrouver les bons délimiteurs.

Cordialement.
Messages postés
4
Date d'inscription
mercredi 4 juillet 2012
Statut
Membre
Dernière intervention
5 juillet 2012
1
Merci pour la réponse,

je crois que je n'ai pas été assez clair:
Mon fichier initial contient des virgules qui doivent servir comme délimiteur ( Je le vérifie sous Notepad ++). quand je l'ouvre sous excel il m'affiche toutes les données dans la première colonne. Donc je passe par Donnée->convertir pour arranger l'affichage. Mais, quand je sauvegarde le fichier, et que je le rouvre sous Notepad++, je crois qu'il a juste remplacer les virgules par des point virgules.

Maintenant que j'y penses peut être que je dois voir du côté des options de sauvegardes.

je ne sais pas si c'est pertinent, mais même dans les formules excel j'ai des points virgules au lieu des virgules ( SOMME(NB1;NB2;....))
Messages postés
4
Date d'inscription
mercredi 4 juillet 2012
Statut
Membre
Dernière intervention
5 juillet 2012
1
Merci Eric!

Tu as raison! c'est bien un windows 7 en français qui a été installé sur la machine!

Du coup, comment faire pour changer? est ce possible?