Variable Php, parametre fonction Javascript

Résolu/Fermé
Signaler
Messages postés
9
Date d'inscription
mercredi 20 décembre 2006
Statut
Membre
Dernière intervention
8 janvier 2007
-
 Amine -
Bonjour,
Je développe depuis peu, et je rencontre de temps en temps des petits problemes, mais celui la me bloque vraiment!

Voila, mon probeme est simple.
J'ai une variable Php :
$VL_TRIGRAMME; // qui contient simplement 'JGI'

j'ai une fonction javascript fnModifier(Parametre)

la fonction est bonne, seulement quand je fais l'appel de ma fonction, ainsi :

echo (' <TD><A Href="javascript:fnModifier('.$VL_TRIGRAMME.');"><IMG src="00_images/modifier.png" border="0"></a></TD></TR>' ) ;

je vois bien dans le navigateur que ma fonction est appelé, et je vois meme le parametre 'JGI' dedans, cependant il ne l'execute pas, car il dis que 'JGI' est indefini.

Quelqu'un pourrait-il m'aider ?
Parceque je suis sur ce probleme depuis plusieurs jours maintenant, et je suis vraiment bloqué !!
merci

5 réponses

Messages postés
3671
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
11 février 2021
1 004
Bonjour,

Le 'JGI' est une chaine de caractère : il faut donc qu'il soit noté comme tel dans l'appel à la fonction JavaScript ! Sinon, le navigateur va chercher une variable JavaScript du nom de JGI dans la page, et, bien sûr, ne la trouveras pas.

Essaie le code suivant :
echo (' <TD><A Href="javascript:fnModifier(\''.$VL_TRIGRAMME.'\');"><IMG src="00_images/modifier.png" border="0"></a></TD></TR>' ) ;
17
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Héhé, à mon tour de te remercier Reivax962 ! T'es un héro..
Je cherchais une solution à un problème qui ne me semblait pas être celui traité par cette question, et pour finir, si, et j'ai résolu mon problème !! Merci à celui qui a posé la question, et à toi Reivax962 pour y avoir répondu avec une très belle précision ^^
Messages postés
232
Date d'inscription
vendredi 27 juin 2008
Statut
Membre
Dernière intervention
12 août 2010
83
Merci bien Reivax962, j'avais fais de simple echo pour passer mes parametres et ca marchait tres bien en FF et IE6 mais pas IE7 qui n'accepte que ta méthode !
Bref merci :p
Merciiiiiiii bcp
Messages postés
327
Date d'inscription
mardi 9 octobre 2007
Statut
Membre
Dernière intervention
31 janvier 2014
41
Bonjour,
Je voudrais remercier de tout mon coeur Reivax962 qui, grâce à sa réponse m'a permis de trouver la solution à mon problème sur le quel je viens de passer une nuit blanche !!
Et tout de même, merci à johandev qui a poser cette question pour le moins très interessante !
MERCIIIIIIIII ! !
C'est genial, ca marche merci Reivax962
Messages postés
9
Date d'inscription
mercredi 20 décembre 2006
Statut
Membre
Dernière intervention
8 janvier 2007
1
ça marche ! merci beaucoup Reivax 962 !
J'ai essayé plein de truc pendant des heures ! mais jamais le bon !
Merci, bientôt plusieurs semaines que je bloquais sur ça, tout le monde me conseillait ajax. C'était bien plus simple bon sang! :D

Moult merci!