Tri de données dans Excel sur une période [Résolu/Fermé]

Signaler
Messages postés
6
Date d'inscription
lundi 4 juin 2012
Statut
Membre
Dernière intervention
14 juin 2012
-
Messages postés
6
Date d'inscription
lundi 4 juin 2012
Statut
Membre
Dernière intervention
14 juin 2012
-
Bonjour,

Je suis à la recherche d'une solution à un problème de tri de données dans excel.
J'ai dans la colonne A un grand nombre de dates. Dans la colonne B des fruits et dans la C une condition Mure dans quelques lignes. Exemple :
Date Fruit Etat
05/01/2012 Pomme
14/01/2012 Poire
20/01/2012 Poire
30/01/2012
06/02/2012 Pomme Mure
07/02/2012 Poire
07/02/2012 Poire
08/02/2012 Poire
10/02/2012 Poire

Je cherche une formule qui me donne le nombre de fruits par type entre le 1er et le 31 janvier, février, etc.. et d'une autre me donnant la même chose, mais en isolant uniquement les fruits murs.
Après pas mal d'essais avec SOMMEPROD, je crains de m'être quelque peu fourvoyé.
Quelqu'un aurait-il la gentillesse de m'aiguiller.
Par avance merci.

2 réponses

Messages postés
25376
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 525
Bonsoir


mettez la date début en X1 la date fin en X2 en X3 le produit cherché(ou ailleurs!)


=SOMMEPROD((A1:A1000>=X1)*(A1:A1000<=X2)*(B1:B1000=X3))
pour avoir le nombre de ligne de produit dans la période

et si jamais vous voulez calculer une quantité (i; faudrait d'abord une colonne où sont placées les quantités mettons D:

=SOMMEPROD(($A$1:$A$1000>=$X1)*($A$1:$A$1000<=X2)*($B$1:$B$1000=X3)*($D$1:$D$1000))




rajouter la 3° conditions en X4 (mure ou pas mure)

et la formule devient:
=SOMMEPROD(($A$1:$A$1000>=X1)*($A$1:$A$1000<=X2)*($B$1:$B$1000=X3)*($C$1:$C$1000=X4))

et donc pour un éventuel cumul de quantités
=SOMMEPROD(($A$1:$A$1000>=X1)*($A$1:$A$1000<=X2)*($B$1:$B$1000=X3)*($C$1:$C$1000=X4)*($D$1:$D$1000))

attention, bien spécifié les limites de champs avec des N° de ligne par ex, le type A:A n'est pas accepté par SOMMEPROD

vous pouvez aussi remplacez les adresses X3 et X4 par les textes correspondants entre guillemets. Pour les dates et pour simplifier la formulation, mieux vaut conserver l'adresse des cellules où vous placez ces dates.

crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
Messages postés
6
Date d'inscription
lundi 4 juin 2012
Statut
Membre
Dernière intervention
14 juin 2012

Bonsoir,

Merci beaucoup, ça répond tout à fait à mon besoin. J'étais parti dans cette direction, mais étant autodidacte, je me retrouve souvent bloqué par des "pas grand choses).
Cdt.