Comparaison de deux fichiers Excel [Résolu/Fermé]

Signaler
-
 PO -
Bonjour Mesdames et Messieurs,

Aprés avoir fait le tour des Forums pour voir si la question avez déjà été posée, je m'en remets à vous n'ayant pas trouvé mon bonheur (je suis peut-être passé à côté, merci de me le signaler si c'est le cas).

Je travaille sur Excel 2010 et je cherche à comparer deux tableaux Excel en fonction de trois colonnes différentes. Toutes les lignes différentes devront être signalé en indiquant 1 dans la derniére colonne disponible.
Pour être plus précis
Fichier 1 colonnes L, M et AH comparées respectivement aux colonnes du fichier 2 L, M et W
Si une ligne du fichier 2 ne trouve pas son semblable dans le fichier 1 on peut mettre 1 dans la colonne Z du fichier 2.

ça fait 1 semaine que je me tire les cheveux à essayer tout style de code mais rien ne marche (je suis pas bon du tout en VBA).

Je vous remercie par avance de votre aide et reste bien entendu à votre disposition pour toutes questions

P.O.
A voir également:

3 réponses

Messages postés
25757
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 janvier 2021
5 723
Bonsoir
...... et au cas où les lignes identiques ne soient pas sur le même N°:
=SI(SOMMEPROD(([Classeur1.xlsx]Feuil1!$L$1:$L$100&[Classeur1.xlsx]Feuil1!$M$1:$M$100&[Classeur1.xlsx]Feuil1!$AH$1:$AH$100=L1&M1&W1)*1);"OK";"non")
(renvoie OK sur toutes les lignes vides dans les deux classeurs)
crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
34
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
551
Bonjour

Si j'ai bien compris la cellule
L1 du classeur 1 doit correspondre à L1 du classeur 2
M1 du classeur 1 à M1 du classeur 2
AH1 du classeur 1 à W1 du classeur 2
c'est trois critères en même temps

Donc voici la formule à mettre en Z1 sur le classeur2

=SI(ET([Classeur1]Feuil1!$L$1=L1;[Classeur1]Feuil1!$M$1=M1;[Classeur1]Feuil1!$AH$1;W1);"identique";"non conforme")

Pour que cela soit plus visible j'ai mis un message "identique" ou "non comforme"
Bonjour,

dsl pour cette réponse tardive merci beaucoup pour les formules bcp plus simple que VBA. Nickel j'ai utilisé la formule de VAUCLUSE car effectivement les lignes ne correspondent pas forcement.

Merci encore.

Bonne journée à vous deux.