[MBR] perdu window$

[Résolu/Fermé]
Signaler
Messages postés
596
Date d'inscription
jeudi 21 février 2002
Statut
Membre
Dernière intervention
25 octobre 2012
-
Messages postés
14
Date d'inscription
samedi 24 mai 2008
Statut
Membre
Dernière intervention
8 octobre 2009
-
Bonjour,

J'ai niqué le MBR de l'ordi de ma fille en installant Freespire.
Ce dernier avait installé Grub en zappant sa partition windows98;
j'ai remplacé Grub (que je ne maitrise pas) par Lilo mais me suis trompé en inversant les options root et boot :-(
bref j'ai écrasé le MBR de windows98.
Du coup, au démarrage, j'ai 2 options: linux, ou windows; mais windows reroute sur sur lilo.
J'ai lancé le cd windows puis fdisk /mbr mais rien.
J'ai tenté avec install-mbr /hda sous linux, mais rien.
J'ai ensuite niqué le mbr (dd if=/dev/zero of=/dev/hda bs=446 count=1), puis restauré a nouveau : install-mbr /hda
mais je reviens à la case départ..
Si j'essaie de relancer une install windows, cette andouille ne me donne d'autre choix que de reformater le windows existant.

Une idée ?

Merci

Thierry

2 réponses

Messages postés
596
Date d'inscription
jeudi 21 février 2002
Statut
Membre
Dernière intervention
25 octobre 2012
118
Bon j'ai trouvé.

J'ai copié le MBR (complet) de windows98 depuis un autre poste:
dd if=/dev/hda1 of=mbr_windows bs=512 count=1

Puis copié ce fichier "mbr_windows" sur le poste qui a perdu windows au mbr, et exécuté:
dd if=mbr_windows of=/dev/hda1

et voili.

Merci qui ? merci moi.
:-)
Messages postés
14
Date d'inscription
samedi 24 mai 2008
Statut
Membre
Dernière intervention
8 octobre 2009

Heu... merci toi!

Maintenant si tu veux bien me la refaire en plus simple avec une mbr d'Xp ca me botterai bien...

je suis dans le mm cas, mbr d'Xp foutu en l'air et comme "fix mbr" ne marche pas avec moi (du au fait qu'il ne detecte pas les DD en format SATA mais seulement IDE) j'ai besoin d'un coup de mains...