Excel : fonction décaler [Résolu/Fermé]

Signaler
Messages postés
47
Date d'inscription
mardi 15 septembre 2009
Statut
Membre
Dernière intervention
26 novembre 2017
-
Messages postés
47
Date d'inscription
mardi 15 septembre 2009
Statut
Membre
Dernière intervention
26 novembre 2017
-
Bonsoir,

J'aimerai savoir s'il est possible d'utiliser la fonction "decaler" entre deux feuilles de calcul.
Je m'explique : j'utilise 2 feuilles avec en lignes des comptes de charges et en colonnes les mois de l'année.
Dans ma feuille "prévisions" l'ai nommé mes lignes de charges (-606200 etc...), dans ma feuille "trésorerie" je désire récupérer le montant concernant mon compte pour le mois m-1 ou m-2 suivant les cas.
D'où mon idée d'utiliser la fonction "decaler" -decaler(-606200;;-1)-, mais j'obtiens le montant correspondant à la colonne dans laquelle je me trouve de la feuille prévision ou l'erreur #REF! si je mets une autre info que -1.
J'ai du zapper une info ou je n'utilise pas la bonne fonction.
Si vous avez des idées.
Cordialement
Daniel



5 réponses

Messages postés
5569
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 juillet 2021
627
Bonjour

Si vos tableaux sont identiques sur les différentes feuilles
le plus simple pour ramener une information est sur la feuille mois de février de mettre la formule qui va chercher sur le mois de janvier l'information correspondante exemple =Janvier!C4. La cellule C4 étant la valeur à récuppérer.

Ou par RechercheV

Si le tableau de Janvier à une colonne de référence sur la feuille du mois de février on met dans la cellule =RechercheV(la référence ex: A5;la table ex: Janvier!$A$5:$R$1000;la colonne ou est l'information ex: 3,pour avoir la valeur exacte ex: faux)
ce qui donne =RECHERCHEV(A5;Janvier!$A$5:$R$1000;3;FAUX)
Pour éviter l'affichage d'erreur on peut mettre un contrôle
=SI(ESTERREUR(RECHERCHEV(A5;Janvier!$A$5:$R$1000;3;FAUX));"";RECHERCHEV(A5;Janvier!$A$5:$R$1000;3;FAUX))

Voila ce que je peux vous proposer
Messages postés
47
Date d'inscription
mardi 15 septembre 2009
Statut
Membre
Dernière intervention
26 novembre 2017

Bonjour,

Merci Philou10120 de ta réponse. Mais il n'y a que deux feuilles, 1 avec les prévisions et l'autre avec les règlements décalé de 1 ou 2 à 3 mois suivant la nature de dépenses. (en lignes des comptes de charges et en colonnes les mois de l'année)
La fonction RechercheV implique que les lignes soient classées dans un ordre croisant, de mémoire? Ce qui n'est pas le cas dans mes tableaux.
Cordialement
Messages postés
5569
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 juillet 2021
627
Non avec RechercheV(a2;d2:j25;2;faux) et si vous mettez l'option faux à la fin la recherche raméne l'information exacte
Messages postés
47
Date d'inscription
mardi 15 septembre 2009
Statut
Membre
Dernière intervention
26 novembre 2017

Merci pour l'info, je vais tester cela. Je vous tiens au courant.
Bon week end
Messages postés
47
Date d'inscription
mardi 15 septembre 2009
Statut
Membre
Dernière intervention
26 novembre 2017

Bonsoir Philou10120

J'ai testé votre formule sur mes tableaux, cela fonctionne à merveille.
Merci pour la proposition qui est pratique et facile à mettre en oeuvre.
Bonne soirée.