Formules imbriquées EXCEL

[Résolu/Fermé]
Signaler
-
 ankh -
Bonjour,

Ma formule ne fonctionne pas sous EXCEL 2010 sans que je n'en trouve les raisons!!!Pouvez-vous m'aider svp!!
D'avance merci :
=SI(H4>25;SI(J4="FAVORABLE";SI(OU(I4="A2+";I4="B1";"O";"N"))))

8 réponses

Messages postés
16513
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2021
3 221
bonjour

Il ne manquerait pas une parenthèse de fermeture du OU?
et peut-^tre la réponse si H4<=25 comme ""
Messages postés
17543
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 septembre 2021
4 737
Salut,

Ta formule ne veut rien dire, explique ce que tu souhaites faire
exemple si H4 est > à 25 je fais
si J4 ="FAVORABLE" je fais etc ...
En fait, c'est dans le cadre de tests dans un lycée, si l'élève obtient une note supérieure à 25, qu'il a un niveau A2+ ou B1, et que l'entretien de motivation est favorable alors il obtient une réponse positive "oui"!
J'ai effectivement ajouté une parenthèse après le "ou" mais il m'indique "FAUX" par moment...
Merci encore
En fait, il m'indique "FAUX" quand il y a dans ma colonne entretien de motivation "a voir"...
Messages postés
10120
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
20 septembre 2021
2 206
bonjour à tous

je crois qu'il te manque quelque chose au niveau des SINON de tes deux premiers SI
par exemple
=SI(H4>25;SI(J4="FAVORABLE";SI(OU(I4="A2+";I4="B1");"O";"N");"Z");"K")
à toi de modifier les "Z" et "K"

bonne suite
Le pb c'est que je ne vois pas du tout par quoi modifier les Z et K, hormis "N", "N"...et ça ne fonctionne pas!
Messages postés
16513
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2021
3 221
re,

=Si(ET(H4>25;J4="FAVORABLE";OU(I4="A2+";I'="B1"));"O";"N")
Messages postés
10120
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
20 septembre 2021
2 206
je ne vois pas ce qui ne marche pas
https://www.cjoint.com/?0Dts7MuWw7I
Merci à vous deux... Elle marche enfin!!!!