Formule calculer la moy d'ancienneté [Résolu/Fermé]

Signaler
Messages postés
27
Date d'inscription
jeudi 12 avril 2012
Statut
Membre
Dernière intervention
2 juillet 2015
-
Messages postés
27
Date d'inscription
jeudi 12 avril 2012
Statut
Membre
Dernière intervention
2 juillet 2015
-
Bonjour,
Je tente de calculer la moyenne d'ancienneté par année financière.

E8:E100 = l'ancienneté de chacun
F8:F100 = oui si à l'emploi ou non si pas à l'emploi durant l'année financière en question

Je veux donc additionner l'ancienneté de chacun si oui dans la colonne F,
diviser ce total par le nombre de oui et x100

Le début de ma formule fonctionne pour additionner l'ancienneté:

=SOMMEPROD((E8:E100)*(F8:F100="oui"))

mais ma fin de formule ne fonctionne pas...

/(SOMMEPROD((B8:B100)*(F8:F100="oui"))*100

Et je ne sais pas ce que j'ai oublié...
Quelqu'un voit mon erreur?

Merci à l'avance!
A voir également:

2 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 397
bonjour,

Ceci devrait te donner la moyenne :

=SOMMEPROD((E8:E100)*(F8:F100="oui"))/(SOMMEPROD((F8:F100="oui")*1)) 

Pour compter le nombre de "oui" il suffit de multiplier par 1.
--
Toujours zen
La perfection est atteinte, non pas lorsqu'il n'y a plus rien à ajouter, mais lorsqu'il n'y a plus rien à retirer. Antoine de Saint-Exupéry
Messages postés
27
Date d'inscription
jeudi 12 avril 2012
Statut
Membre
Dernière intervention
2 juillet 2015

Merveilleux!
Merci beaucoup gbinforme! :)