Macro excel recherche d'une valeur

Fermé
sparx971 - 10 avril 2012 à 18:06
gbinforme Messages postés 14946 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 - 11 avril 2012 à 19:00
Bonjour,

J'ai un petit soucis dans l'élaboration d'une macro.

J'ai 2 feuilles dans mon classeur

Je voudrais rechercher dans la colonne B de la feuille 2 si la valeur qui se trouve dans la cellule A1 de la feuille 1 est présente

Je ne sais pas trop comment coder ça en VBA

Si quelqu'un sait comment s'y prendre, j'aimerais bien quelques conseils

Merci d'avance



A voir également:

3 réponses

gbinforme Messages postés 14946 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 689
10 avril 2012 à 18:27
bonjour,

Tu peux le faire sans macro avec cette formule :

=SI(ESTERREUR(EQUIV(A1;Feuil2!B:B;0));"absent";"présent")


Si tu tiens à avoir une macro tu peux faire ainsi :

Public Sub cherche_A1()
Dim sel As Variant
Set sel = Sheets("Feuil2").Columns("B").Find(Sheets("Feuil1").Range("A1"))
If sel Is Nothing Then
    MsgBox "absent"
Else
    MsgBox "présent"
End If
End Sub
0