[samba]problem authentificat° user: linux win [Résolu/Fermé]

Signaler
Messages postés
21
Date d'inscription
mardi 14 novembre 2006
Statut
Membre
Dernière intervention
24 janvier 2007
-
Messages postés
21
Date d'inscription
mardi 14 novembre 2006
Statut
Membre
Dernière intervention
24 janvier 2007
-
Bonjour à tous, etant novice en linux j'ai du mal avec l'authentification des utilisateurs quand il se connecte au serveur pourtant j'ai mis aucune authentification dans smb.conf et egalement tout ce qui va avec

guest ok = yes
security = share
map to guest = bad user

et pourtant a chaque fois que je veu m'y connecté soit depuis windows pour aller sur le repertoire partager linux soit depuis linux pour aller sur le repertoire partager windows.

Comment faire?

et surtout d'ou viens le probleme?

Je n'ai peut etre pas été suffisament clair donc n'hesiter pas a me le dire que je puisse vous donnez les info en plus necessaire a la resolution de ce probleme

Merci.

6 réponses

Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 858
Salut,

Affiche-nous ton "/etc/samba/smb.conf" :
egrep -v "^(#|$)" /etc/samba/smb.conf
Côté réseau, le ping entre tes machines passe bien au moins ?
Messages postés
21
Date d'inscription
mardi 14 novembre 2006
Statut
Membre
Dernière intervention
24 janvier 2007

Oui sans probleme les ping passe d'une machine a l'autre;

Voici mon smb.conf:

# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE
# Date: 2004-10-05
[global]
workgroup = INTERNET
# printcap cache time = 750
# cups options = raw
printer admin = @ntadmin, root, administrator
# username map = /etc/samba/smbusers
map to guest = Bad User
# include = /etc/samba/dhcp.conf
# logon path = \\%L\profiles\.msprofile
# logon home = \\%L\%U\.9xprofile
# logon drive = P:
# add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
# domain logons = yes
ldap idmap suffix = ou=Idmap
ldap machine suffix = ou=Computers
os level = 65
preferred master = yes
wins support = no
# ldap suffix = dc=example,dc=com
guest ok = yes
########################################MODIF DETEC##################
# client code page = 850
guest ok = yes
# character set = ISO8859-1
dos charset = 850
unix charset = utf8
server string = InternetLinux
hosts allow = 192.168.0. 254.
printcap name = cups
load printers = no
printing = cups
guest account = nobody
log file = /var/log/samba/%m.log
max log size = 1000
security = share
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
unix password sync = no
passwd program = /usr/bin/passwd%u
passwd chat = *New*password*%n/n*Retype*new*password*%n/n*passwd:*all*authentification*tokens*updated*successfully
pam password change = no
obey pam restrictions = no
socket options = IPTOS_LOWDELAY TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
########################################MODIF DETEC##################
domain master = no
dns proxy = no
preserve case = yes
local master = no
short preserve case = yes
case sensitive = no
netbios name = internet
passdb backend = smbpasswd
#############################SHARE DEFINITIONS#######################
[printers]
comment = All Printers
path = /var/spool/samba
printable = no
browseable = no
guest ok = yes
use client driver = no
printer admin = root
writeable = no
create mask = 0777

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

[telechargements]
comment = Telechargements
path = /Telechargements/
read only = no
printable = no
create mask = 0777
directory mask = 0777
guest ok = no
guest only = no
writeable = yes
guest ok = yes
security = share
map to guest = Bad User
hosts allow = 192.168.0. 254.

En ajoutant les trois dernière ligne j'ai reussi a avoir acces au repertoire sous partagé sous linux depuis windows mais depuis linux je ne peu pas aller sur le repertoire windows partagé
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 858
Inutile de répéter les directives, et surtout ne pas mettre ensemble des directives contradictoires :-\
[telechargements]
comment = Telechargements
path = /Telechargements/
read only = no
printable = no
create mask = 0777
directory mask = 0777
guest ok = no
guest only = no
writeable = yes
guest ok = yes
security = share
map to guest = Bad User
hosts allow = 192.168.0. 254. 
Essaie comme ça :
[telechargements]
comment = Telechargements
path = /Telechargements/
read only = no
printable = no
create mask = 0777
directory mask = 0777
public = yes
browseable = yes
N'oublie pas de relancer "samba" après les modifs :
/etc/init.d/smb restart
Quant à "mais depuis linux je ne peux pas aller sur le repertoire windows partagé", c'est plus du côté Windows qu'il te faut chercher que côté GNU/Linux...

;-))
Messages postés
21
Date d'inscription
mardi 14 novembre 2006
Statut
Membre
Dernière intervention
24 janvier 2007

Merci je modifi sa, et pour ce qui est du coté windows je regarde dans le partage mais ou vais je trouver l'utilisateur linux sous windows pour lui donner acces?

Désolée si m'ai question sont un peu nul!! lol

Merci
Oui je m'explique:

Pour ce qui est de du partage:

depuis la machine windows vers le partage linux (Sans probleme)

Par contre:

depuis la machine linux pour le partage windows la sa pose probleme car il me demande de m'authentifier a chaque fois

Comment puis je faire?

Merci
Messages postés
21
Date d'inscription
mardi 14 novembre 2006
Statut
Membre
Dernière intervention
24 janvier 2007

Bonjour a tous,

je confirme le probleme venait bien du coté de windows, il suffit de mettre les utilisateurs authentifié pour l'acces a distance de la machine linux (serveur samba)...... et tout va bien !!!!!

Mais quelque petit probleme se pose quand meme au niveau des droits pour les utilisataurs externe!!!

Merc a tous.

Ce post est terminée.