20 go utilisable sur 500 go avec Linux

Fermé
Lilly97 - 17 mars 2012 à 17:42
 Utilisateur anonyme - 9 avril 2012 à 21:41
Bonjour,

J'ai depuis peu un ordi portable acer de 500 go sous linux. Mais je ne sait pas pourquoi Opensuse ne me permet d'en utilisé que 20 GO. Je ne suis pas une grande pro de l'informatique mais j'ai beaucoup cherché et trouvé aucune solution. Si vous pouviez m'aider Merci d'avance.
A voir également:

5 réponses

Pierrecastor Messages postés 41055 Date d'inscription mercredi 5 novembre 2003 Statut Modérateur Dernière intervention 22 janvier 2023 4 182
17 mars 2012 à 17:51
Salut

Tu peut poster le resultat de la commande :

fdisk -l
0
CouCou.
Si je devait le rentrer dans le terminal cela me dit rien du tout :s
0
Voila Pierrecastor, je ne sait pas si c'est ce que tu voulais exactement mais j'ai obtenu ceci
Usage:
fdisk [options] <disk> change partition table
fdisk [options] -l <disk> list partition table(s)
fdisk -s <partition> give partition size(s) in blocks

Options:
-b <size> sector size (512, 1024, 2048 or 4096)
-c[=<mode>] compatible mode: 'dos' or 'nondos' (default)
-h print this help text
-u[=<unit>] display units: 'cylinders' or 'sectors' (default)
-v print program version
-C <number> specify the number of cylinders
-H <number> specify the number of heads
-S <number> specify the number of sectors per track
0
Pierrecastor Messages postés 41055 Date d'inscription mercredi 5 novembre 2003 Statut Modérateur Dernière intervention 22 janvier 2023 4 182
28 mars 2012 à 19:02
Ha, tu a du faire une erreur, tu à bien mis -l (L minuscule) ?
0
ah d'accord. désolé j'ai cru que c'était un trait.
voila :

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 têtes, 63 secteurs/piste, 60801 cylindres, total 976773168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x000effb6

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 2048 4208639 2103296 82 Linux swap / Solaris
/dev/sda2 * 4208640 46153727 20972544 83 Linux
/dev/sda3 46153728 976773119 465309696 83 Linux
0
Utilisateur anonyme
25 mars 2012 à 21:15
Bonsoir,
C'est une commande à lancer avec des droits admin, su ou sudo.
0
Merci
0
Utilisateur anonyme
2 avril 2012 à 09:12
Bonjour,
Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 2048 4208639 2103296 82 Linux swap / Solaris
/dev/sda2 * 4208640 46153727 20972544 83 Linux
/dev/sda3 46153728 976773119 465309696 83 Linux
Cela nous fait une partition swap de 2Go, une partition bootable (le *) de 20Go
et une partition de 465 Go (le tout arrondi) donc grosso-modo 488Go ce qui correspond bien à un disque de 500Go.
Il faut regarder dans /ect/fstab où est montée la partion sda3, ou nous copier coller ici le contenu de /ect/fstab (c'est du texte).
A tout hasard regarder dans /Media s'il n'y a pas un volume vide de 465Go qui traine.
0
Bjr ^^ merci pour votre aide et voici ce que j'ai pu obtenir du fichier "fstab"

# /etc/fstab: static file system information.
#
# Use with care
# Modified Sam Smie
# Compiled SAM.SMIE
# Trust openSuse from SHAMAD Limbada
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda1 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=92979ee7-2953-4f29-9234-e44bcb4c2817 none swap sw 0 0
0
Utilisateur anonyme
4 avril 2012 à 21:23
Bonsoir,
Il y a une antinomie entre /ect/fstab et le résultat de fdisk -l.
fdisk -l donne une partition primaire de swap (/dev/sda1) et deux partitions primaires linux (/dev/sda2 et /dev/sda3) alors que fstab donne une partition primaire / (/dev/sda1) et une logique de swap (/dev/sda5).
Il faudrait voir avec un éditeur de partitions ce qu'il en est.
En supposant que fdisk -l ait donné les bonnes infos vous pouvez essayez ceci:
créez dans /home/votre-répertoire-personnel un répertoire Test, puis, en root, tapez: mount -t ext4 /dev/sda3 /home/votre-répertoire-personnel/Test
Si sda3 n'a pas été formaté en ext4 il faut adapter la commande bien entendu.
Ensuite, si cela n'a pas généré d'erreur, vous devriez accéder aux Go manquants dans Test.
Pour rendre ceci permanent il faudra modifier le fstab (en root) en ajoutant une ligne du genre:
/dev/sda3 /endroit-ou-monter-la-partition ext4 defaults 0 2
Si sda3 n'a pas été formaté en ext4 il faut adapter là aussi.
Tant que tout ceci n'est pas testé et fiabilisé, ne pas mettre de données importantes sur /dev/sda3 bien entendu.
0
Bonsoir, je rencontre un problème de taille pour votre explication. Je suis allé dans /home/ mais là c'est que je ne peut pas creer de nouveaux dossiers. Et j'avoue ne pas trouver cela normal.

Merci de votre aide.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Utilisateur anonyme
9 avril 2012 à 21:41
Bonsoir,
Si, c'est normal.
Ce n'est pas dans /home/ mais dans /home/votre-répertoire-personnel/ (dont j'ignore le nom, c'est peut être /home/lily) que vous pouvez créer un répertoire.
Le nom de "votre-répertoire-personnel" apparait quand vous ouvrez un terminal:
votre-répertoire-personnel@nom-du-PC:~$
Vous avez regardé avec un éditeur de partitions ?
0