Pourcentage réalsé avec des valeurs négatives

Fermé
Mmmoooiii Messages postés 1 Date d'inscription samedi 17 mars 2012 Statut Membre Dernière intervention 17 mars 2012 - 17 mars 2012 à 08:39
 axion - 20 mars 2012 à 18:56
Bonjour,
Voilà je voudrais calculer le pourcentage de réalisation.
avec des valeurs positives pas de soucis , le problème apparait lorsqu'on a des valeurs négatives ex:

objectif réalisé janvier pourcentage de réalisation
50 100
-50 -100
50 -100
-50 100
50 0
-50 -50

Merci pour votre aide
Je travaille sous Excel mais si déjà j'avais la bonne formule mathématique cela m'aiderait

2 réponses

Raymond PENTIER Messages postés 56714 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 6 octobre 2022 17 183
18 mars 2012 à 03:55
Donne quelques détails.
Comment un objectif de réalisation peut-il être négatif ?
De quoi s'agit-il exactement ?
La formule sera fonction de la réalité physique à traiter.
2
bonjour,
je vois ce post tardivement et je propose une formule valable pour tout nombre,
EXCEPTE le 0 (diviser par zéro est une gageure, l'inverse aussi)

soit en A: un nombre de départ (positif ou négatif)
en B: un nombre d'arrivée (positif ou négatif)
en C: =SI(OU(A2=0;B2=0);"";(B2-A2)/A2*SI(A2>0;1;-1))
C est formaté en %, bien sûr
à confirmer si j'ai bien compris l'énoncé
cordialement
axion
0
dans le cas d'une recherche d'évolution AVEC le 0,
la formule peut devenir :
=SI(ET(A2=0;B2=0);"";SI(ET(A2=0;B2>0);1;SI(ET(A2=0;B2<0);-1;SI(ET(B2=0;A2>0);-1;(B2-A2)/A2*SI(A2>0;1;-1)))))
elle donnera le ±100% aux valeurs partant ou arrivant à 0
0