Wamp your port 80 is actually used by ?

[Résolu/Fermé]
Signaler
Messages postés
250
Date d'inscription
lundi 9 mars 2009
Statut
Membre
Dernière intervention
4 décembre 2013
-
Messages postés
250
Date d'inscription
lundi 9 mars 2009
Statut
Membre
Dernière intervention
4 décembre 2013
-
Bonjour,

En voulant tester webmatrix , je ne pourrai plus executer quoi que ce soir sur Wamp en faisant localhost et quand je vais dans Apache -> services ->tester port 80 un message affiche comme quoi c déjà occupé

your port 80 is actually used by :
Server : Microsoft HTTPAPI/2.0


il y a déjà des sujets qui évoquent le problème et incitant à désactiver sql reporting services" mais quand je me rends dans services , je ne vois rien de ce qu'ils indiquent !!

l'autre option que j'ai essayé et qui marche c de configurer en changeant httpd.conf en utilisant un port 8080 mais voilà quand je teste des codes sur le framework CodeIgniter le résultat ne semble pas ce qu'on attendait donc je souhaite revenir et travailler avec localhost tout court !!
quelqu'un aura une idée pour arrêter ou désactiver ce truc merci afin que je puisse revenir sur localhost


3 réponses

Messages postés
5630
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
13 octobre 2021
950
Salut razily,

Tu dis que tes problèmes ont débuté après avoir installé Webmatrix. Sauf erreur Webmatrix installe un service dénommé "Web Deployment Agent Service" qui occupe le port 80.

Vois si ce service est en cours d'exécution sur ta machine et désactive le, ou mets le en lancement manuel.

Deviner quel programme lance le service s'identifiant comme "Microsoft HTTPAPI/2.0" n'est pas aisé (cela peut être IIS, sql reporting services, Skype, etc. ; en fait tout programme utilisant l'API de Microsoft pour créer un service web).

Pour le déterminer, tu peux faire ceci en tant qu'administrateur dans une console :

netstat -abv > resultat-connections.txt   
notepad resultat-connections.txt 

L'exécution de netstat avec ces paramètres va prendre un moment.

Recherche dans notepad la ligne comportant le port ":80" ou ":http". Tu verras à la suite les informations concernant le nom du programme responsable du lancement de ce service.


Dal
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
5630
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
13 octobre 2021
950
Salut razily,

As-tu bien mis les options "-abv" à netstat ? As-tu bien cherché ":80" ou ":http" dedans ? As-tu exécuté netstat en tant qu'administrateur ?

Pour désactiver le service ou changer son mode de lancement en "manuel", dans "Démarrer-Exécuter" tape "services.msc", clic droit sur le service, Propriétés. Puis redémarre ta machine. Bien sûr, tu dois être administrateur pour faire cela.

Tu peux aussi arrêter le service à partir de cet outil, en principe.


Dal
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
250
Date d'inscription
lundi 9 mars 2009
Statut
Membre
Dernière intervention
4 décembre 2013
2
oui echec de l'initialisation des sockets !!!
mais je te remercie pour ta réponse , finalement j'ai décidé de tout supprimer avec webmatrix étant donné que ce logiciel ne marche pas comme je le souhaite car j'ai eu du mal à entrer dans la base !!mainetenant je peux travailler correctement sur Wampserver avec localost
Messages postés
250
Date d'inscription
lundi 9 mars 2009
Statut
Membre
Dernière intervention
4 décembre 2013
2
justement j'ai lancé netstat via executer et il ne m'affiche rie sur le port 80 !!
j'ai fait ce que tu me dis mais accès refusé !!
le sujet a évoqué même ici :
http://www.devlog.nl/apache-on-port-80-blocked-by-microsoft-httpapi2-0/

quand j'ai essayé de suivre et de trouver ce qu'il préconise , étant donné que je suis en langue française sur vista j'ai trouvé ce qu'il dit d'arrêter le fameux MsDepSvc described as "Web Deployment Agent Service"
mais quand je veux arrêter le processus : c impossible de le faire !! je ne sais pas pour quelle raison . du coup j'ai regardé sur installer et désinstaller le programme et voir la date où j'ai installé webmatrix je me suis aperçu que ce logiciel a installé pas mal de truc !!! ceci dit 2 solutions s'offrent :
1) désinstaller un par un tout ces programmes avec Webmatrix
et configurer Apache (car je l'ai mis port 8080 ) à 80

2) configurer Apache via httpd.conf sans désinstaller quoi que ce soit sur Webmatrix

mais j'ai opté pour la première option car webmatrix , j'avais même eu du mal à me connecter dans la base !!