Excel 2010 somme conditionnelle

Résolu/Fermé
Signaler
-
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
-
Bonjour,


Colonne A = Période | Colonne B=Pays | Colonne C= chiffre à additionner

J'aimerai savoir comment je peux additionner les chiffres de la colonne C qui respectent ces 2 conditions :

Sur la colonne A = Période 1 (je n'ai que 2 périodes donc sélection = Période 1 ou 2)
Sur la colonne B = je veux pouvoir sélectionner plusieurs pays.... Bref, comment donner plusieurs valeurs à un critère ?

J'ai testé les fonctions bdsomme, somme.si, somme.si.ens mais cela ne fonctionne pas ...

Une autre idée ?

Merci d'avance

4 réponses

Messages postés
10731
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
22 janvier 2022
1 249
Bonjour,
Avec une explication plus claire, un exemple concret ... !
0
N'arrivant pas à joindre un fichier, je vais essayer de détailler.

Dans la colonne A = période = je n'ai que Période 1 ou 2
Dans la colonne B = Pays = Allemagne, France, Italie, Espagne, Suisse, Etc, ...
Dans la colonne C = les chiffres à additionner.

Et ce que je voudrais par exemple, c'est faire l'addition pour la période 1 et pour la France, l'Allemagne et la Suisse par exemple.
C'est donc une somme avec une valeur déterminée sur un critère et le choix de plusieurs valeurs sur un autre critère.
C'est possible ça ?
Merci d'avance
0
Messages postés
10731
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
22 janvier 2022
1 249
Bonjour feu31,
Selon ce que j'ai compris : en colonne [A] valeur 1 ou 2, en colonne [B] nom d'un pays et en [C] des nombres
Cette formule en [E1] : =SOMMEPROD((A2:A15=2)*(B2:B15="Allemagne");C2:C15)
Salutations.
Le Pingou
0
Merci beaucoup ... J'ai testé et en effet cette formule marche pour une période et un pays...
Mais je voudrais pouvoir sélectionner plusieurs pays...
Bref, obtenir la somme des chiffres en colonne C pour une période et plusieurs pays
J'ai donc essayé formule en [E1] : =SOMMEPROD((A2:A15=2)*(B2:B15="Allemagne")*(B2:B15="France")*(B2:B15="Suisse";C2:C15) et j'obtiens 0.
Une idée ?

En tout cas, merci beaucoup pour votre aide et vos réponses rapides.
0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 185
Bonjour:
Pour feu
essayez
SOMMEPROD((A2:A15=2)*((B2:B15="Allemagne")+(B2:B15="France")+(B2:B15="Suisse"))*(C2:C15))

et pour sousou:
=SOMMEPROD((ANNEE(champA)=année cherchée)*(MOIS(champA)=N° du mois cherché)*(champB))
crdlmnt
0
Messages postés
10731
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
22 janvier 2022
1 249
Bonjour,
Merci, j'ai la même solution que l'ami Vaucluse.
Salutations.
Le Pingou
0
Si je peut me permettre d'expliquer j'ai un peu le même problème :

Exemple :

Colonne A = DATE
Colonne B = NOMBRE

Le résultat voulu :

La Somme des nombres de la colonne B qui respecte un critère de DATE ( Les dates comprises dans le mois de janvier 2012)



Je suis tomber la dessus qui apporte un élément de reponse :

http://www.admexcel.com/fmath.htm
0
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 677
Bonjour,

Tout d'abord, je vous souhaite une très bonne année à tous, Vaucluse, Le Pingou, sousou et feu, pour vous et vos proches une excellente année 2012!...

Ensuite, j'y vais de ma pitite formuleà 5€...
Partant de la formule de Vaucluse, agrémentée d'une matricielle de Boisgontier (pour les amateurs...) on peux avec :
- colonne A : des 1 ou des 2,
- colonne B : des noms de pays,
- colonne C : des nombres,
- en D1 : le 1er critère,
exemple : 2
- en D2 : les noms des pays cherchés, tout collé :
exemple : AllemagneRoyaume UnisFrance
la formule est :
=SOMMEPROD((A1:A40=D1)*(ESTNUM(EQUIV("*"&B1:B40&"*";D2;0)))*C1:C40)
Elle est pas belle? Franchement...
Si si ça fonctionne, la preuve...
0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 185
Bonjour Pijaku
et bonne année puisque nous ne l'avons semble il pas encore souhaitée
ensuite, effectivement, la formule est belle, et surtout elle montre ce que l'on peut faire avec le code EQUiV, à l'inverse de chercher un texte dans un champ, à savoir chercher si
le texte d'u n champ appartient au texte d'une cellule.
Merci
Crdlmnt
0