RechercheV+Concatener+ Automatisation

Résolu/Fermé
Signaler
Messages postés
43
Date d'inscription
jeudi 7 mai 2009
Statut
Membre
Dernière intervention
5 mars 2012
-
Messages postés
43
Date d'inscription
jeudi 7 mai 2009
Statut
Membre
Dernière intervention
5 mars 2012
-
Bonjour,

j'aimerais savoir si il est possible de faire une rechercheV additionner à une fonction concatener pour automatiser les calcules.


J'aimerai que ma fonction rechercheV recherche une valeur dans une plage de donnée indiquée dans la cellule A2. Cette cellule A2 change continuellement selon que je travaille sur tel ou tel pays. Du coup j'aimerais bien que les rechercheV soient flexibles (que je n'ai pas à les changer à chaque fois à la main).

J'ai fais un essai, =RECHERCHEV($F13;CONCATENER("'Global Rating 2010";A2);6;0)

Cette formule demande de rechercher la valeur de la cellule F13 dans la plage de donnée de A2 de l'onglet "GLobal Rating 2010".

A2= est une plage de donnée qui varie tout le temps tout comme le numéro de colonne 6.
si j'écris le concatener j'obtiens :
CONCATENER("'Global Rating 2010";A2)= 'Global Rating 2010'!$H$7:$M$9999
ce qui me semble est une adresse correct.

Cependant j'obtiens un #Valeur.

Si vous avez une autre solution a me proposer.

Merci d'avance pour votre aide.


2 réponses

Messages postés
16546
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 janvier 2022
3 259
Bonjour


si A2 contient la plage de recherche il faut utiliser la fonction INDIRECT

par exemple
=RECHERCHEV(F$13;INDIRECT("'Global Rating 2010'!"&A2);2;0)
lire guillemets apostrophe....... apostrophe exclamation guillemets
0
Messages postés
43
Date d'inscription
jeudi 7 mai 2009
Statut
Membre
Dernière intervention
5 mars 2012

Merci Beaucoup Michel_m Pour votre réponse,
Vous venez de me sortir une grosse aiguille du pied.
0