Excel formule - somme de 2 critères [Résolu/Fermé]

Signaler
Messages postés
240
Date d'inscription
mercredi 14 juillet 2010
Statut
Membre
Dernière intervention
20 décembre 2011
-
Messages postés
4
Date d'inscription
samedi 18 mai 2013
Statut
Membre
Dernière intervention
19 mai 2013
-
Bonjour à tous,

J'ai un tableau, en colonne A des Prénoms et en B des nombres.

Benoit 1
Michel 2
Benoit 5
Elodie 3
Michel 1

J'aimerais par exemple avoir pour "Benoit" le total des nombres le concernant. Benoit : 6

Comment faire ?

J'ai essayé sommeprod mais je pense que ce n'est pas adapté, ou c'est moi qui ne sait pas m'en servir.

Merci pour votre aide !



4 réponses

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
804
Salut le forum

Avec un SOMME.SI
=SOMME.SI(A1:A5;"Benoit";B1:B5)

Avec un SOMMEPROD
=SOMMEPROD((A1:A5="Benoit")*B1:B5)

Mytå
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Messages postés
240
Date d'inscription
mercredi 14 juillet 2010
Statut
Membre
Dernière intervention
20 décembre 2011
17
Bon c'est moi alors qui sait pas m'en servir !

En tout cas, Merci beaucoup, ca marche ! ;-)
Bonjour,

sur le même exemple cité précédemment, est-il possible dans la formule de ne pas donner la condition d'un prénom et avoir le résultat pour tous?
ou:
Autrement dit, dans une feuille de calcul j'ai un tableau récapitulatif nominatif, je veux rapatrier la somme des données de mon autre tableau où j'ai en colonne A les prénoms et en colonne B les nombres.

Je ne m'en sors pas.
Merci d'avance pour votre réponse.
Stéphanie
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 491
Bonjour stéphanie

On ne comprend pas bien là?
si vous voulez la somme totale, faites simplement le total du champ non?
=SOMME(B:B)
et si vous avez des montants en B avec une cellule vide en A que vous ne voulez pas inclure
=SOMME.SI(A:A;"<>";B:B)

et si vous avez en A une liste de noms dont seulement quelques uns sont à considérer dans la somme
faites la liste des ces prénoms, hors champ 'exemple E1:E19) et appliquer la formule:
=SOMMEPROD((NB.SI(E2:E19;A2:A100))*(B2:B100))

Et enfin pour avoir les sommes par prénoms listés, remplacer le nom par l'adresse de la cellule qui le contient:
exemple pour une liste démarrant en A1 feuil2, mettre en B1:


=SOMME.SI(Feuil1!A:A;A1;Feuil1!B:B)
et tirez cette formule sur la hauteur de la liste

crdlmnt


Errare humanum est, perseverare diabolicum
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 255
Salut le fil,

Bonjour Teani_T à l'avenir évite de créer des demandes en doublon même en changeant de pseudo, fortement déconseillé, cela n'a pour effet que disperser les réponses et abuser des intervenants au détriment d'autres demandes et la moindre des correction est de répondre à chaque intervenant qui a apporté gratuitement son savoir et pris le temps de proposer une solution

https://forums.commentcamarche.net/forum/affich-27837017-formule-somme-avec-condition#top

cordialement

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
4
Date d'inscription
samedi 18 mai 2013
Statut
Membre
Dernière intervention
19 mai 2013

Bonjour

Merci "Vaucluse" pour ce petit cours qui va bien me servir!
et oui je suis complétement perdue! ce qui est certain c'est qu'avec vos réponses je vais m'en sortir alors merci!!!


A Mike-31 je ne sais pas si vous vous adressez à moi, je suis nouvelle et j'ai profité du cas de Teani-t qui ressemble au mien pour faire ma demande mais je ne m'étais pas encore inscrite du coup, c'est possible que j'ai fait une demande en doublon, je sais pas. En tout cas désolée si j'ai fait une bêtise!

Bien cordialement.