[ubuntu-mandriva] probleme de son [Résolu/Fermé]

Signaler
-
 fabss -
bonjour,

quand je lance xmms &, et que je veux lire un mp3, parfois il j'ai le message suivant, dans une boite de dialogue :

en entete : Impossible d'ouvir l'audio

veridier que :

1 - votre carte son est correctement configuré
2 - vous avez selectionné le greefon de sortie correct
3 - Aucun programme ne bloque la carte son

j'ai ce meme message aussi bien sous ubuntu que mandriva. mais par exemple il suffit que je redemarre et je n'ai plus ce probleme sur les 2 distros.

par contre sur Debian je n'ai jamais eu ce probléme.

merci de votre aide a savoir comment reparer ce probleme sans devois redemarrer la disto a chaque fois ?

bonnne soirée
fabss

6 réponses

Messages postés
29982
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
22 juillet 2021
7 139
Ca m'est arrivé et je n'ai jamais trouvé ce qui provoquait ça. Quand ça m'arrive (toujours avec xmms d'ailleurs), je quitte xmms et je relance / recharge les scripts alsa :
/etc/init.d/alsa-utils restart

ou un truc dans le genre, cf ce qui commence par alsa dans /etc/init.d. Ensuite je relance xmms et tout va bien ;)

Bonne chance
Bonjour mamiemando et merci pour ta réponse.

des que cela recommence je relancerai le script alsa.

merci encore
bonne journée
re,

bon j'ai juste le scripte alsa, dans /etc/init.d

j'ai beau faire restart ça ne arche pas.

Sinon j'ai reussit a avoir un message console, si ça vous dit quelque chose.

** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): Aucun fichier ou répertoire de ce type

Merci de votre aide
Messages postés
29982
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
22 juillet 2021
7 139
Ah ben c'est ça le problème :) /dev/dsp c'est le fichier dans lequel on écrit pour jouer u nson et là il n'est pas créé. Essaye de faire
cd /dev ; ./MAKEDEV
ls -l /dev/dsp

Donne moi le résultat de ces commandes, mais ça peut suffir à te débloquer. Sinon, donne moi aussi les résultats de :
cat /etc/group | grep audio
whoami

Bonne chance
Salut mamiemando,

Dés que le probleme se représente, je fais tout ça.

hier soir en redemarrant le fichier /dev/dsp etait présent..
c'est bizarre qu'en redemarrant un coup il apparait un coup nan ...

je vous tiens informé.
bonne journée
re,

bien en fait j'ai reussi avec la commande alsaconf

effectivement ça redemarre alsa et ça fonctionne apres

wala
bye