Prob excel pour faire un récap de 52 feuilles

Résolu/Fermé
ph - 18 nov. 2011 à 11:30
 ph - 23 nov. 2011 à 08:59
Bonjour,
je travaille sur excel.
j'ai 52 onglets qui correspondent aux 52 semaines de l'année (s1, s2, s3....)
les onglets sont identiques. il sagit du temps de travail des agents.
un onglet contient le temps de travail de 12 agents (heures de jour , heures de nuit..)
je souhaite faire un récapitulatif sur un nouvel onglet "récap"
dans l'onglet "récap", pour l'onglet "s1", je vais chercher les cellules en faisant ='s1'!b1 par exemple.
quand j'ai fais le travail pour toutes les cellules qui se trouvent sur l'onglet "s1", je bloque les cellules (puisque d'un onglet à un autre se sont les mêmes tableaux) et je fais copier:coller pour avoir sur l'onglet "récap" les données de l'onglet "s2" sur les mêmes cellules. mon problème, c'est que le numéro de l'onglet ne change pas. existe t'il une solution?

si vous avez compris ma question

merci par avance





5 réponses

slt, a tu bien penser a mettre les parenthese et le + ?
0
merci pour votre réponse, j'ai trouvé la solution dans la réponse à un autre internaute. je crois que j'avais pas bien expliqué mon problème . la solution passe par la fonction =indirect(.... merci encore
0
oui, la recpie se fait bien. c'est le numéro de l'onglet qui reste le même ce qui est normal. je cherche une solution pour pouvoir recopier et que l'onglet change
0
michel_m Messages postés 16579 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 1 octobre 2022 3 279
18 nov. 2011 à 16:20
Bonjour

Ce que tu voudrais, est ce par exemple la somme de tous les 52 b1?
0
merci pour votre réponse, j'ai trouvé la solution dans la réponse à un autre internaute. je crois que j'avais pas bien expliqué mon problème . la solution passe par la fonction =indirect(.... merci encore c tres sympa
0
eriiic Messages postés 24452 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 30 septembre 2022 7 133
18 nov. 2011 à 16:22
Bonjour,

Bien que tu ne le dises pas je suppose que c'est lors de la recopie des formules que tu as un pb.

Ex pour récupérer s2!C2 :
en A1: s2 (le nom de l'onglet)
en B1: =INDIRECT(A1& "!C2")

Et si ton nom d'onglet peut avoir des espaces :
=INDIRECT("'" & A1& "'!C2")
bien lire " ' " et " '

eric
0
merci pour votre réponse, j'ai trouvé la solution dans la réponse à un autre internaute. je crois que j'avais pas bien expliqué mon problème . la solution passe par la fonction =indirect(.... merci encore c tres gentil
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Raymond PENTIER Messages postés 56699 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 1 octobre 2022 17 176
18 nov. 2011 à 23:12
Bonjour ph.

Puisque les feuilles sont identiques, pour totaliser les cellules F8 il faut :
. saisir =SOMME(
. sélectionner ensemble les 52 feuilles (avec la touche Maj)
. cliquer sur la cellule F8 affichée
. fermer la parenthèse
. valider la formule.
la formule ressemblera à =SOMME('s1:s52'!F8)

* c'est ce qu'on appelle usuellement une formule en 3 dimensions, employée pour les opérations de consolidation.
0
merci pour votre réponse, j'ai trouvé la solution dans la réponse à un autre internaute. je crois que j'avais pas bien expliqué mon problème . la solution passe par la fonction =indirect(.... merci encore pour votre aide
0