Afficher le nb d'occurence de chaque ligne

[Résolu/Fermé]
Signaler
-
 Zylé -
Bonjour,

Je suis sûre que c'est réalisable, mais je n'ai pas trouvé l'info.
(J'utilise Excel 2007).

J'ai une base de données avec plusieurs informations du type:

Nom Prénom Identifiant client
X _____a_____89****
X _____a_____89****
Y _____b_____45****
Z _____c_____33****
Z _____c_____33****
Z _____c_____33****

Je voudrais faire apparaître dans une 4e colonne le nombre de fois que j'ai le même identifiant.
Je voudrais obtenir ce résultat:

Nom Prénom Identifiant client Nb d'occurence
X _____a_____89****________2
X _____a_____89****________2
Y _____b_____45****________1
Z _____c_____33****________3
Z _____c_____33****________3
Z _____c_____33****________3

Merci de m'indiquer la solution la plus simple svp :)




1 réponse

Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 059
Bonjour
dans la colonne du résultat:
si vos identifiants sont en C et la colonne résultat en E à partir de ligne 2:

en E2
=NB.SI(C:C;C2)
à tirer sur la hauteur utile

Pour info:
si vous voulez le résultat uniquement sur la ligne ou apparait l'identifiant pur la première fois:
=SI(NB.SI($C$2:C2;C2)=1;NB.SI(C:C;C2);"")
les lignes sans résultats sont donc des doublons

crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
C'est parfait!
Merci beaucoup!