EXCEL - "Compter avec une condition"

Résolu/Fermé
Signaler
-
 Clément -
Bonjour tout le monde !


Je reviens vers vous car la dernière fois que j'ai posé une question ici la réponse était quasi-immédiate et de qualité. En espérant que ce soit de même cette fois-ci ;)


Pour faire simple, j'ai un tableau avec 1000 lignes et 3 colonnes (par exemple).
-> 1ère colonne : Nom (invariable)
-> 2ème colonne : Condition 1 (Oui ou Non ou vide)
-> 3ème colonne : Condition 2 (Oui ou Non ou vide)

Ce que je souhaite faire, c'est un tableau qui me compte le nombre de lignes avec les conditions 1=Oui et 2=Oui, le nombre de lignes en 1=Oui et 2=Non, le nombre de lignes avec les condition 1=Non et 2=Non et enfin le nombre de lignes avec 1=vide et 2=vide.

Il me semble que c'est un tableau croisé mais je ne m'y connais vraiment pas assez en bureautique.

Désolé pour le titre pas trés explicite mais je ne savais pas comment nommer ce topic ^^.


Merci pour le temps que vous consacrerez à me lire et m'aider.

C Ya !

Clément



3 réponses

Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
Bonjour



cell1=SOMMEPROD((Champ1="oui")*(Champ2="oui"))
cell2=SOMMEPROD((Champ1="non")*(Champ2="non"))
cell3=Nombre de lignes du champ - cell1-cell2

crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
2
Bonjour,

qu'est ce que tu entends par champ ?

Si je suis amené à changer les valeur des conditions, le comptage s'actualisera automatiquement?
0
Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
voyez le message suivant avec le modèle joint
A +
0
Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
Pour traiter l'ensemble de vos cas de figure, voyez le fichier ci joint et prenez ce qui vous intéresse:

http://www.cijoint.fr/cjlink.php?file=cj201110/cijCUk4OVe.xls

crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
1
Ahhh ! Ok je crois que je viens de comprendre pourquoi ce que j'avais tappé ne fonctionnait pas.

=SOMMEPROD((I2:I984="NON")*(J2:J984="0"))

Je crois que le "0" ne convient pas. l'erreur peut-elle venir de là ? (Dans mon tableau, les Vide sont en réalité des 0)


Merci bcp pour ce tableau.

Bonne soirée à vous deux !
0
Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
oui, l'erreur vient bien de là, le 0 entre guillemet correspond à du texte, pas à une valeur num ou à une cellule vide.
bonne route, au plaisir
0
Merci, ça fonctionne impeccable.

Bonne continuation
0
Bonjour,

Une question dans la continuité de ma question précédente.

Au lieu de compter le nombre de fois ou les deux conditions cumulées apparaissent, je souhaiterais faire la somme des valeurs qui sont en face de ces deux conditions cumulées.

Petit exemple pour expliciter ce que j'ai du mal à explqiuer :
Colonne A = cond 1 (oui ou non)
Colonne B = cond 2 (a, b ou c)
Colonne C = valeur (numérique)

A | B | C
1 OUI | a | 12
2 OUI | c | 0.5
3 NON | a | 51
4 OUI | a | 5
5 NON | a | 0.2


Ce que je souhaiterais, c'est un case qui me fait la somme des valeur en face des OUI/a donc ici 12+5 (17), une autre qui me somme les veleurs en faces des NON/a donc ici 51+0.2 (51.2) etc

N'hésitez pas à me demander des précisions si besoins.

Cordialement.

Clément
0
Résolu avec la fonction :

=SOMME(SI((Plage1="Cond1")*(Plage2=Cond2);Plage_à_sommer;à_faire_sinon))

A plus tout le monde
0
Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
350
Vous utilisez la formule NB.SI
=NB.SI(plage de la colonne 1;condition1)+NB.SI(plage de la colonne 2;condition 2)
Ou condition 1 ou 2 prennent les valeurs "oui", "non" ou "" pour vide
Michel
0
Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
350
Vous pouvez jumeler les plages pour une comptage d'un seul critère comme ceci :
=NB.SI(plage des colonnes 1 et 2;"Oui")
0
Ca fonctionne nickel !

Encore une victoire de canard euh... du fofo !

Merci beaucoup pour la rapidité de ta réponse mic13710
0
ah...petit problème.

Comment faire pour qu'il ne me compte pas deux fois les mêmes ?

Je m'explique

A | Non | Vide
B | Non | Non
C | Non | Non


Si je veux le nombre de Non ET Vide uniquement donc ici 1 et pas 3.
Et le nombre de Non ET Non uniquement donc 2 et non 3.


Je suppose qu'il suffit de remplacer le + par une sorte de AND exclusif non?
0
Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
350
Excusez-moi pour la réponse trop rapide.
Je pensais que vous vouliez le nombre de récurrences alors que vous voulez le nombre de lignes.
Allez-voir la réponse de Vaucluse qui est plus appropriée que la mienne.
0