Arrondir au nombre entier [Résolu/Fermé]

Signaler
Messages postés
11
Date d'inscription
jeudi 15 septembre 2011
Statut
Membre
Dernière intervention
3 août 2016
-
 emmilly -
Bonjour,

Bonjour,

J'ai un tableau sous excel 2010 ou je voudrais arrondir au nombre entier.

Exemple: disons que je total de la cellule est 15.01 je voudrais que le nombre soit arrondi a 16 comment dois-je faire?

j'ai plusieurs cellules qui contiennent deja une formule a arrondir de cette facon comment dois-je faire pour que la formule s'applique a toutes les cellules?


6 réponses

Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 350
Il faut d'abord utiliser les bon mots. L'arrondi est une opération mathématique clairement identifée, et qui suit ses règles propres. On devrait donc utiliser la fonction =ARRONDI(cellule;nombre_de_chiffres_à_arrondir).

Si tu as 3.141597 dans la cellule A1:

=ARRONDI(A1;0) donne 3 comme résultat
=ARRONDI(A1;1) donne 3.1 comme résultat
=ARRONDI(A1;2) donne 3.14 comme résultat
=ARRONDI(A1;3) donne 3.142 comme résultat
etc...

Et pour l'arrondi supérieur:

=ARRONDI(A1+1;0) donne 4 comme résultat

et grâce à la transitivité de l'addition, c'est la même chose que

=ARRONDI(A1;0)+1, qui donne également 4 comme résultat

Pour l'appliquer à plusieurs cellules, tu tires la formule.
Pour l'appliquer directement sur ton addition, tu écris =ARRONDI(SOMME(A1:A10;1);0) ou =ARRONDI(SOMME(A1:A10);0)+1

Ce n'est pas un représentant de commerce: c'est ton papa !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Merci Bruce tu est vrt tout puissant!
Messages postés
12186
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
15 octobre 2020
2 522
Bonjour,
Pour arrondir une somme (total) de cellules (D1:D5 dans l'exemple) à l'entier supérieur :
=ARRONDI.SUP(SOMME(D1:D5);0)
Pour modifier toutes tes formules, il faudra le faire manuellement (eh oui!).
Cordialement,
Franck P
Messages postés
538
Date d'inscription
vendredi 20 mai 2011
Statut
Membre
Dernière intervention
8 janvier 2018
94
Bonjour Picard47at,

Pourquoi dans ta cellule, tu ne mettrais pas :

=ARRONDI.SUP(10,16;0)


Le premier paramètre serait ta somme et le second la précision de l'arrondi, autrement dit, 0 c'est-à-dire arrondir à l'unité supérieure.
Messages postés
11
Date d'inscription
jeudi 15 septembre 2011
Statut
Membre
Dernière intervention
3 août 2016

Je ne suis pas vraiment familier presentement dans une de mes cellules la formule est:
=((D2*J10)/1000)-H10 ce qui donne un total de 15.01 comment je dois l'ecrire pour que mon resultat soit 16.

Merci de votre patience et de vos reponses :)
Messages postés
538
Date d'inscription
vendredi 20 mai 2011
Statut
Membre
Dernière intervention
8 janvier 2018
94
Comme cela :
=ARRONDI.SUP(((D2*J10)/1000)-H10;0)
Messages postés
11
Date d'inscription
jeudi 15 septembre 2011
Statut
Membre
Dernière intervention
3 août 2016

Merci Heremion ca fonctionne comme je voulais.