Fonction aujourd'huit

[Fermé]
Signaler
-
 domi 46 -
Bonjour,
j'utilise une fonction AUJOURDHUI() qui ce déclenche en fonction du resultat d'une case
mais le lendemain je voudrais qui la date de la case ne change pas
exemple :
le 06/09/11
B12 : 1 alors B13 :=SI(B12=1;AUJOURDHUI();"") donc B13 = 06/09/11

le 07/09/11
B12 : 1 B13 :=SI(B12=1;AUJOURDHUI();"") mais dans B13 il doit y avoir la date du
06/09/11

C12 : 1 alors C13 :=SI(B12=1;AUJOURDHUI();"") donc B13 = 07/09/11

etc

merci
domi46

1 réponse

Messages postés
24182
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 886
Bonsoir,

Vu qu'aujourdhui() change tous les jours tu ne peux utiliser cette fonction.

Utilise le raccourci clavier pour la date : ctrl+; dans B13, C13,.... plutôt que de mettre 1 dans B12, C12, ...
vba ne vaut pas le coup juste pour ça.

eric
çA ne marche pas
Messages postés
24182
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 886
Si !
et bonjour, merci c'est quand tu veux...
Adios
il faut faire "ctrl" point virgule