[Excel] Somme cellules paires d'une colonne?

Fermé
Danucci - 19 juil. 2006 à 16:54
 jonniop - 27 août 2007 à 15:42
Bonjour, je ne connais pas trop toutes les fonctionnalités d'excel mais j'aimerais savoir comment calculer la somme des cellules paires d'une colonne entre la ligne 4 et 204 par exemple (ou une ligne sur deux si vous preferez)
en effet je ne peux pas tous les énumérer dans la somme sinon la fonction est trop longue

donc y a-t-il une formule telle que je pourrais choisir les numéros de cellules en indiquant qu'ils soient du genre 4+i*2 avec i compris entre 0 et 100 à la façon d'un algorithme?
et en général, y a-t-il une façon de faire où je pourrais mettre n'importe quelle formule à la place de "4+i*2"?

Merci à ceux qui m'aideront. Ciao!

7 réponses

gbinforme Messages postés 14935 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 629
21 juil. 2006 à 09:10
bonjour

comment calculer la somme des cellules paires d'une colonne entre la ligne 4 et 204 par exemple

Pour faire cela, il y a la possibilité d'utiliser cette formule :

=SOMME((MOD(LIGNE(A4:A204);2)=0)*B4:B204)

Comme c'est une formule matricielle, il faut la valider avec Ctrl + Maj + Entr

Cette formule vérifie si le N° de ligne est pair pour l'additionner.

Pour cumuler les lignes impaires la formule est :

=SOMME((MOD(LIGNE(A4:A204);2)<>0)*B4:B204)

J'ai considéré que la colonne à cumuler était la colonne B,
si c'est la D il faut mettre D4:D204 bien sûr, par contre,
pour le test de ligne, on peut laisser la colonne A dans tous les cas.


y a-t-il une façon de faire où je pourrais mettre n'importe quelle formule à la place de "4+i*2"?

Là je ne comprend pas la question et si tu veux expliquer autrement...

3
Bonjour,
Et pour faire la somme de cellules (toujours une sur deux) via les colonnes.

=SOMME((MOD(LIGNE(A4:A204);2)<>0)*B4:B204)
devient :
=SOMME((MOD(LIGNE(A24:EQ24);2)<>0)*B25:EQ25)


Je suppose que ça ne doit pas marcher ? :'(

Quelqu'un a-t-il une idée?
1
Utilisateur anonyme
19 juil. 2006 à 20:48
je ne connais pas excel car je travaille sous openffice mais je pense que c'est a peu pres la même chose.

Ce que tu peux faire c'est rajouter 2 colonnes.

-> Dans la premiere colonne, première ligne tu marques 1 (ou 0 si tu ne veux pas compter la valeur de cette cellule dans ta somme). Dans les autre lignes tu marques =if (C1 ==1; 0; 1)

Si tu mets cette formule dans le colonne C et que tu as mis 1 (ou 0) dans la cellule C1. Tu auras donc une colonne de 0 et de 1 se succedant.

-> Ensuite dans la 2e colonne tu marques, =if (c1==1; b1;0)

Si les valeurs que tu veux faire la somme sont dans la colonne B


Voici ce que tu auras :


B----------C----------D

12---------1---------12
2-----------0---------0
35---------1---------35


Il ne te reste plus qu'a faire la somme sur la colonne D pour avoir la somme d'une valeur sur 2.
0
gbinforme Messages postés 14935 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 629
24 août 2007 à 15:44
bonjour

Je suppose que ça ne doit pas marcher ? :'(

Si tu l'avais testé, tu aurais vu que cela fonctionne parfaitement.

Cependant l'utilisation est limitée, car pour être utilisée, les données des colonnes doivent être de nature identique.

Si tu as en ligne les éléments d'une même commande par exemple : en ligne paire le nombre d'articles, et en ligne impaire leur montant.
Cela te permet alors de faire le total général en nombre et montants.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Re,

Si si j'avais essayé la commande. Elle ne fonctionne pas, elle me retourne la valeur 0. (les valeurs tout le long de la ligne sont identiques.)


Bref, okay koi.
0
gbinforme Messages postés 14935 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 629
25 août 2007 à 23:54
bonjour
=SOMME((MOD(LIGNE(A24:EQ24);2)<>0)*B25:EQ25)

effectivement, je comprends ce que tu veux faire mais ta formule n'est pas adaptée.

Celle-ci :
=SOMME((MOD(COLONNE(B25:EQ25);2)<>0)*B25:EQ25)

est adaptée aux colonnes et cumule les impaires, mais il faut que tes matrices aient la même taille,
c'est-à-dire que les colonnes soient identiques ce qui n'est pas le cas avec A24:EQ24 et B25:EQ25.

Ainsi ,ceci donne le même résultat, car comme tu cumules la ligne 25, tu peux regarder le code impair de la colonne sur n'importe quelle ligne.
=SOMME((MOD(COLONNE(B1:EQ1);2)<>0)*B25:EQ25)
0
Bonjour,
Merci pour les réponses. Ca fonctionne impec ;)



Bien le boujou,
0