Mise en forme conditionnelle/ formule EXCEL

[Résolu/Fermé]
Signaler
-
 steph138 -
Bonjour,

J'ai un probleme mineur mais j'arrive pas a écrire la bonne formyule dans excel 2007

Voila le pb :

je veux que quand je tape "majeur" dans A1, un 1 se mette dans A2, de meme quand je tape moyen dans A1 , j'ai un 2, et quand j'ai soir faible soit non-significatif dans A1 j'ai un 3 dans A2

J'ai essay" de faire la formule avec SI, des ET et des Ou mais j'ai toujours un probkleme dans la formule et je vois pas d'ou ca vient.

Voila merci d'avance pour vos réponses.

2 réponses

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 284
Bonjour,

la demande n'a rien à voir avec la mise en forme conditionnelle, qui s'occupe de modifier la police, les bordures ou le remplissage d'une cellule.

La il s'agit d'une simple imbrication de SI :
=SI(A1="majeur";1;SI(A1="moyen";2;SI(OU(A1="faible";A1="non-significatif");3;"")))


à écrire en A2.

Cordialement.
Super merci

oui c'est vrai c'est pas de la mise en forme conditionnelle deésolé^^
Messages postés
54733
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 septembre 2021
16 622
Bonjour.
Il ne s'agit donc pas de mise en forme conditionnelle (couleur de police et de remplissage) mais de formule conditionnelle (avec fonction logique).

La formule à mettre dans A2 est
=SI(A1="majeur";1;SI(A1="moyen";2;3))

et, si tu veux éviter d'avoir le chiffre 3 quand A1 n'est pas encore renseigné,
=SI(A1="";0;SI(A1="majeur";1;SI(A1="moyen";2;3)))
... tu peux remplacer le 0 par "", mais ça gêne parfois dans les opérations suivantes.

Cordialement.